Bug 463945 - seinfo segfaults when there is a space between option and its argument
seinfo segfaults when there is a space between option and its argument
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: setools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 12:32 EDT by Milos Malik
Modified: 2010-02-03 03:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 08:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-09-25 12:32:55 EDT
Description of problem:
The seinfo utility segfaults anytime I write a space between option and its argument. I found it out by accident, because I believed that all utilities await a space there.

Version-Release number of selected component (if applicable):
setools-3.0-3.el5

How reproducible:
always

Steps to Reproduce:
# seinfo -g iso9660
Rule loading disabled
Segmentation fault
# seinfo -t bin_t
Rule loading disabled
Segmentation fault
# seinfo -c dir
Rule loading disabled
Segmentation fault
#

Actual results:
A space between option and its argument causes a segfault.

Expected results:
A space between option and its argument does not cause a segfault.

Additional info:
Comment 1 Daniel Walsh 2008-09-25 15:23:57 EDT
Yes it thinks bin_t is a policy file.

Seems to work on rawhide version.  Perhaps we should just move to the upstream version or setools.

Note You need to log in before you can comment on or make changes to this bug.