Bug 464056 - fix configure script failure on sh arch.
fix configure script failure on sh arch.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
rawhide
sh4 Linux
medium Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 23:44 EDT by CHIKAMA Masaki
Modified: 2008-12-11 03:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 07:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
octave-filter-asoption.patch (515 bytes, patch)
2008-09-25 23:44 EDT, CHIKAMA Masaki
no flags Details | Diff

  None (edit)
Description CHIKAMA Masaki 2008-09-25 23:44:40 EDT
Created attachment 317762 [details]
octave-filter-asoption.patch

Description of problem:
 This patch enables to compile octave on sh architecture.
On this arch, gcc(gfortran) passes "-little" option to gas 
when compiling for backward compatibility. 
The configure script fails because of it.
I also sent a patch for autoconf package beacuse
this configure script was generated by autoconf.
(see Bug #456886)

--- octave-3.0.0/configure.org  2008-08-08 18:51:07.000000000 +0900
+++ octave-3.0.0/configure      2008-08-08 18:51:31.000000000 +0900
@@ -11078,7 +11078,7 @@
                                                                                
           ;;
           # Ignore these flags.
-        -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | LIST:* | -LNO:*)
+        -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | LANG:=* | -LIST:* | -LNO:*)
           ;;
         -lkernel32)
           test x"$CYGWIN" != xyes && ac_cv_f77_libs="$ac_cv_f77_libs $ac_arg"

Version-Release number of selected component (if applicable):
 octave-3.0.2-1
Comment 1 Rakesh Pandit 2008-10-23 02:29:49 EDT
Did you sent it upstream ?
Comment 2 CHIKAMA Masaki 2008-10-23 04:01:00 EDT
No. Not yet.
Could you contact upstream and push the patch please ?
Comment 3 Rakesh Pandit 2008-10-23 04:16:17 EDT
I see the patch sane, so I will apply it. I will drop it in some time soon. - Thanks. I will push the patch with latest release. Octave needs some cleaning. Keeping watching ... 

Thanks
Comment 4 CHIKAMA Masaki 2008-10-23 04:22:35 EDT
Thank you. I'll make efforts to contact upstream in myself from now on.
Comment 5 Fedora Update System 2008-10-23 07:14:52 EDT
octave-3.0.2-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/octave-3.0.2-2.fc8
Comment 6 Fedora Update System 2008-10-23 07:15:40 EDT
octave-3.0.2-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/octave-3.0.2-2.fc9
Comment 7 Rakesh Pandit 2008-10-23 07:18:04 EDT
CLOSED -> RAWHIDE
Comment 8 Fedora Update System 2008-12-11 02:58:14 EST
octave-3.0.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-12-11 03:03:37 EST
octave-3.0.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.