Bug 464058 - An unhandled exception has occurred in Package Updater.
An unhandled exception has occurred in Package Updater.
Status: CLOSED DUPLICATE of bug 452538
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-updatesd (Show other bugs)
5.4
x86_64 Linux
medium Severity urgent
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 00:13 EDT by kitamura
Modified: 2008-09-26 00:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 00:43:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kitamura 2008-09-26 00:13:03 EDT
Component: Software Updater
Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-client-workstation-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 324, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 380, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 228, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 622, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 222, in _YumRepository__get
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-client-workstation-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-x86_64-client-workstation-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0x1ba9df50>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-x86_64-client-workstation-5/updateinfo.xml.gz
Comment 1 James Antill 2008-09-26 00:43:41 EDT

*** This bug has been marked as a duplicate of bug 452538 ***

Note You need to log in before you can comment on or make changes to this bug.