Bug 464096 - [RFE] Please add support for IPv6 to tftp
[RFE] Please add support for IPv6 to tftp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tftp (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: 5.4
Assigned To: Jiri Skala
BaseOS QE
: FutureFeature, Rebase, Triaged
: 474706 (view as bug list)
Depends On:
Blocks: 445204
  Show dependency treegraph
 
Reported: 2008-09-26 05:14 EDT by Tomas Smetana
Modified: 2014-11-09 17:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
tftp has now been rebased to version 0.49. This applies several upstream feature updates and bug fixes, including support IPv6.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:37:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2008-09-26 05:14:17 EDT
Description of problem:

The tftp server and client package that RHEL distributes doesn't work with IPv6.

Version-Release number of selected component (if applicable):

tftp-server-0.42-3.1

How reproducible:
always

Steps to Reproduce:
1. edit /etc/xinet.d/tftp, change flags = IPv4 to flags = IPv6
2. use "curl -6 tftp://serverhostname/filename" to download a file via IPv6
3. try tftp client, but there is no way to specify that IPv6 should be used

Expected results:

We should really upgrade, patch, or switch to a server/client for TFTP that
supports IPv6.
Comment 3 Jiri Skala 2008-12-11 04:18:52 EST
*** Bug 474706 has been marked as a duplicate of this bug. ***
Comment 4 IBM Bug Proxy 2008-12-11 04:23:28 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> -
1. Feature Overview:
Feature Id:	[201224]
a. Name of Feature:	Enable IPv6 support in tftp client/server
b. Feature Description
Add IPv6 support to tftp client and server packages.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Delivery Mechanism: Direct from community
Category:	Networking
Request Type:	Package - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	tftp-hpa - Hosted at:
ftp://ftp.kernel.org/pub/software/network/tftp/

3. Business Case
tftp is one of the component that is required to enable network boot/install. IPv6 support in tftp
is required for network boot/install in a IPv6 only network environment.

4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Sridhar Samudrala, samudrala@us.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
The bug duplicates #464096 and the implementation of IPv6 is currently in F-9.

*** This bug has been marked as a duplicate of 464096 ***
Comment 5 Jiri Skala 2008-12-11 04:41:53 EST
The implementation is in Fedora.
Comment 8 Jiri Skala 2009-04-14 03:16:34 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
tftp has now been rebased to version 0.49. This applies several upstream feature updates and bug fixes, including support IPv6.
Comment 11 IBM Bug Proxy 2009-07-20 01:50:36 EDT
------- Comment From iranna.ankad@in.ibm.com 2009-07-20 01:48 EDT-------
As per IBM internal comments#8, #9 & #12, TFTP over IPv6 has no issues on both SystemX & ppc.

Thanks!
Comment 13 errata-xmlrpc 2009-09-02 05:37:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1274.html

Note You need to log in before you can comment on or make changes to this bug.