Bug 464179 - [LTC 6.0 FEAT] 201729:FCP - Performance data collection (blktrace)
[LTC 6.0 FEAT] 201729:FCP - Performance data collection (blktrace)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Eric Sandeen
Mike Gahagan
: FutureFeature
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-26 11:30 EDT by IBM Bug Proxy
Modified: 2010-10-23 00:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: blktrace-1.0.1-3.1.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-26 11:30:23 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:22 EDT
1. Feature Overview:
Feature Id:	[201729]
a. Name of Feature:	FCP - Performance data collection (blktrace)
b. Feature Description
The item comprises:
    a) facilities which provide performance relevant data (see below) at any time
    b) facilities which collect the data provided by a), then associate it with a time stamp and and
store it for future processing
         - these facilities are configurable in regard of the type and amount of data collected for
the purpose of reducing the amount of temporarily stored data.
         - when data is taken as samples, the sampling interval is configurable
         - collected data can be filtered by e.g masks for valid stack components (see below) before
data is stored for further processing
 Data collected comprises:
    a) Performance relevant data about stack components as Linux devices, SCSI LUNs and HBA and
storage controller information
    b) Per stack component: current values of relevant measurements as throughput, utilization and
other applicable measurements
     c) Statistical aggregations (min, max average, histogram) of data associated with I/O requests
as size, latency per component and in total.      
Pick up latest version from blktrace package and if IBM contribution, not yet included, apply it.

Additional Comments:	This feature is the blktrace part to feature 201591 FCP - Performance Data
collection & analysis (userspace),  and feature 201590 FCP - Performance Data collection (kernel)

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Direct from community
Category:	RAS
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	> blktrace 0.99.3

3. Business Case
This item will make possible to have a better understanding of the SCSI activities and performance
of the customer system, being able afterward to better solve FCP issues regarding customer's SCSI
workloads.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 2 IBM Bug Proxy 2009-03-03 14:33:16 EST
This feature has two required co-feature requests to be complete,
that are
48075 ??-?? RHBZ 463689 [LTC 6.0 FEAT] 201590:FCP - Performance Data collection (kernel)
48076 ??-?? RHBZ 463688 [LTC 6.0 FEAT] 201591:FCP - Performance Data colletion & analysis (userspace)
Comment 3 IBM Bug Proxy 2009-03-03 17:00:59 EST
The code for this feature is accepted with blktrace 1.0.0

When RHEL 6 includes blktrace 1.0.0, this part of the feature is fulfilled
Comment 4 IBM Bug Proxy 2009-05-19 02:30:38 EDT
------- Comment From mgrf@de.ibm.com 2009-05-19 02:24 EDT-------
Hello Red Hat, Hello Eric,

Same as discussed for RHEL 5.4 feature (LTC 50351 - RHBZ 472898) applies for this same R6 request.

For awareness copy the comments here also

We recognized that the upstream revision level of blktrace did not change after
accepted commits made it into blktrace.

To ensure the level of blktrace (1.0.0) and commits get included into RHEL 5.4
that are required to fulfill this feature request
here a list of required commits for reference:

Here's info on the blktrace version needed:
blktrace 1.0.0 with all patches up to January 22, which is (git commit ids):
cdc033a3e6615142697e99b6be43319b8b8233e9
e47ada103e028a691d296d09d0bc673a3af6a3dc
f3db34733e7c8a46e9e26305e424a3ecd49ac06d
d00dcee7f0d77f64c59ee47bfcf09809dad366ff
9638f3909854d936f4a55a48f787364abdbda71f
a22df989ded0fb438dcad77a08c59a1a16b6b849
7ae1d0bfcaaf46102fb747a4a21fcbe0a1887800
0f067275d74a96ca9d574e9912a60bfa81b4df97
ef02006b0131f298595b37afb07562ee50fae5cc
19cfaf3f4d8e53ce43cccd809676f8f2a40f0b34
b3ee499dd143aeaed311bf3bc6d14871168b6657
61165962f86cb2de0b163f6083bff5649f692e91
(end of patches up to January 22)

f547a39d32d514eb7bce82b955193b73e9828c85
(Tom Zanussi fix for race that bit us)

8d388c8ea6a58186bfdf7ca7fc4e1268eced8b14
b5f8804a588fffdea10a0cd46a36fc196acea9f2
(Martin's latest two patches)

=====================================

be careful about the blktrc 1.0.1:
The code that we shipped is not compatible with 1.0.1,
since af90543f47f93782df94a3a56d4f607f4dd6ad4c breaks an ABI we rely on
- we would have to update our code to work with that version.
Comment 10 John Jarvis 2009-12-17 11:39:57 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux major release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux major release.   
While it is a goal to include this enhancement in the next major release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next major release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 12 IBM Bug Proxy 2010-01-15 14:33:13 EST
48075 ?-? RHBZ 463689 [LTC 6.0 FEAT] 201590:FCP - Performance Data collection (kernel)
48076 ?-? RHBZ 463688 [LTC 6.0 FEAT] 201591:FCP - Performance Data colletion & analysis (userspace)
Comment 14 Eric Sandeen 2010-01-22 11:42:08 EST
All the bits should be in, and have been for a while now.
Comment 15 Dennis Gregorovic 2010-02-04 22:42:45 EST
# find RHEL6.0-20100203.3/6/{StandardServer,Workstation}/i386/os/ -name *blktrace*
RHEL6.0-20100203.3/6/StandardServer/i386/os/Packages/blktrace-1.0.1-3.1.el6.i686.rpm
RHEL6.0-20100203.3/6/Workstation/i386/os/Packages/blktrace-1.0.1-3.1.el6.i686.rpm
Comment 16 Mike Gahagan 2010-06-10 16:36:10 EDT
Confirmed blktrace is in the current B2 candidate tree, also confirmed basic functionality on x86_64, note that debugfs must be mounted for it to work:

mount -t debugfs none /sys/kernel/debug
Comment 17 releng-rhel@redhat.com 2010-07-02 14:58:48 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.
Comment 19 IBM Bug Proxy 2010-08-17 03:21:45 EDT
------- Comment From mgrf@de.ibm.com 2010-08-17 03:13 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx

Note You need to log in before you can comment on or make changes to this bug.