Bug 464214 - After installation, grub will only boot to Fedora, and has no entry for Windows Vista....
After installation, grub will only boot to Fedora, and has no entry for Windo...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 334701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 14:44 EDT by Jim Gettys
Modified: 2009-06-18 14:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 14:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Gettys 2008-09-26 14:44:53 EDT
Description of problem:

After installation, grub only had an entry to boot fedora, and did not have
an entry to boot Windows Vista on the other primary partition.

Version-Release number of selected component (if applicable):
  The not quite beta from alt of:
  F10-Beta-i686-Live.iso           25-Sep-2008 22:49  697M

How reproducible:


Steps to Reproduce:
1. Install onto new system
2. resize the main partitions
2a. Lose multiple times trying previous spins of the previous days, in the
step after installing the image to disk.
3. Successfully finish the installation with the above image
4. boot; find that grub does not stop and advertise a windows partition to me.

The menu.lst file only has an entry for Fedora
  
Actual results:


Expected results:

I would have expected another grub entry, with Windows Vista as the other 
possibility.

Additional info:
Comment 1 Jim Gettys 2008-09-26 15:33:27 EDT
editing /boot/grub/menu.lst for the "Other" entry, changing
  rootnoverify (hd0,1)
to
  rootnoverify (hd0,2)
And now I can boot to Windows Vista....
Comment 2 James Laska 2008-09-26 16:46:31 EDT
Booting to Fedora after an install is expected if you've instructed the installer to install the bootloader into the master boot record.  You can confirm this by inspected the /root/anaconda-ks.cfg file contents on your recently installed fedora system.

The portion of it not detecting your Windows partition ... I'm not entirely clear on how the "Operating system" partition detection code works.  Perhaps the anaconda-devel folks can recommend some further information that might help pinpoint the problem.
Comment 3 Deji Akingunola 2008-10-24 00:08:59 EDT
I can confirm this bug with fresh installations of F10 Snapshot 2 and rawhide of 20081023. My laptop (Dell Vostro 1700) has 2 hard drives; the first drive has the default Dell installations, and I've installed Fedora on the second. Anaconda incorrectly detect the second partition of the first drive as the windows boot partition, whereas it is located on the third partition. The previous F8 and F9 installations on the system got it right. 
>>
[root@logos ~]# parted /dev/sda
GNU Parted 1.8.8
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                            
Model: ATA FUJITSU MHW2160B (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  82.3MB  82.2MB  primary   fat16             
 2      82.8MB  10.8GB  10.7GB  primary   ntfs              
 3      10.8GB  157GB   147GB   primary   ntfs         boot 
 4      157GB   160GB   2684MB  extended               lba  
 5      157GB   160GB   2683MB  logical   fat32             

(parted) quit                                  
<<

Jim,

Anaconda has always (as far as I can remember from Redhat 9) label MS Windows partitions as 'Other' in the grub entry. Judging from comment #1, the Windows Vista entry was actually put there by anaconda.
Comment 4 Bug Zapper 2008-11-25 22:14:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chris Lumens 2009-04-16 16:37:58 EDT
We've done a major storage rewrite and sucked booty back into anaconda, so it's worth testing this again with rawhide.  Could anyone do this and let me know whether it works or not?  Thanks.
Comment 6 Christopher Beland 2009-04-23 13:32:11 EDT
*** Bug 334701 has been marked as a duplicate of this bug. ***
Comment 7 Christopher Beland 2009-04-23 13:36:19 EDT
One person reported the same problem with Ubuntu and Debian against an older version (Bug 452545), but I have asked them to re-test and report back here.  At least one other person on the mailing list reported no problems dual-booting with Windows and Rawhide, so this might be either hardware/configuration-specific, or fixed.  Thanks all!
Comment 8 Ronald L Humble 2009-05-01 08:33:50 EDT
Installed F11-Preview-i686-Live-KDE on dual boot machine with F10. Installed to existing LVM structure where 3 blank ext4 partitions existed. /boot is ext2 on /dev/sda1 and installation of new bootloader was selected. Only a single F11 entry existed in /boot/grub/grub.conf. -RoyBoy626
Comment 9 Morgan Olausson 2009-05-03 06:23:06 EDT
I installed F11-preview-i686-live-gnome for dual boot with existing Ubuntu9.04.
There are no grub menu entry for Ubuntu, so I do not know how to start Ubuntu. Help appreciated. "fdisk -l" attached so maybe somebody could help...
Comment 10 Keith Roberts 2009-05-03 12:31:28 EDT
@ Morgan:

You will need to start F11-preview and edit your /boot/grub/grub.conf file and manually add the entry for Ubuntu9 to F11-preview boot menu.

To do this I would:

create a mountpoint for the Ubuntu root partition, say /mnt/Ubuntu9/.

Mount the Ubuntu9 root partition there.

Then take a look in /mnt/Ubuntu9/boot/

You should see something like this, but relevant to Ubuntu9:

-rw-r--r-- 1 root root   88385 2008-10-17 21:10 config-2.6.26.6-49.fc8
-rw-r--r-- 1 root root   88396 2008-12-19 00:27 config-2.6.26.8-57.fc8
drwxr-xr-x 3 root root    4096 2009-01-11 21:33 grub
-rw------- 1 root root 3057331 2008-10-30 19:05 initrd-2.6.26.6-49.fc8.img
-rw------- 1 root root 3057476 2009-01-11 21:32 initrd-2.6.26.8-57.fc8.img
-rw-r--r-- 1 root root  934839 2008-10-17 21:10 System.map-2.6.26.6-49.fc8
-rw-r--r-- 1 root root  934955 2008-12-19 00:27 System.map-2.6.26.8-57.fc8
-rw-r--r-- 1 root root 2133568 2008-10-17 21:10 vmlinuz-2.6.26.6-49.fc8
-rw-r--r-- 1 root root 2133920 2008-12-19 00:27 vmlinuz-2.6.26.8-57.fc8

Backup your working F11-preview /boot/grub/grub.conf file and then add the appropriate entry there to boot Ubuntu9. Just follow the example in your F11-preview /boot/grub/grub.conf for F11, and use it as a pattern.

Next time you boot F11-preview you should also see the grub entry for Ubuntu9 you have added to /boot/grub/grub.conf
Comment 11 Andy Lindeberg 2009-06-18 14:03:23 EDT
(In reply to comment #8)
> Installed F11-Preview-i686-Live-KDE on dual boot machine with F10. Installed to
> existing LVM structure where 3 blank ext4 partitions existed. /boot is ext2 on
> /dev/sda1 and installation of new bootloader was selected. Only a single F11
> entry existed in /boot/grub/grub.conf. -RoyBoy626  

This is expected behavior - if you install a new bootloader, anaconda does not go looking for other Fedora installs.

Closing as RAWHIDE, which the original problem seems to have been fixed in.

Note You need to log in before you can comment on or make changes to this bug.