Bug 464237 - /usr/bin/svn linked against version of shared library not present
/usr/bin/svn linked against version of shared library not present
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subversion (Show other bugs)
5.2
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Joe Orton
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 16:01 EDT by Stephen P. Schaefer
Modified: 2008-09-29 05:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 05:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen P. Schaefer 2008-09-26 16:01:57 EDT
Description of problem:

/usr/bin/svn is linked against shared library libdb-3.3.so which is not present in the OS.

Version-Release number of selected component (if applicable):

1.4.2-2.el5.i386

How reproducible:

Always (on i386; works on x86_64)

Steps to Reproduce:
1. /usr/bin/svn help
2.
3.
  
Actual results:
/usr/bin/svn: error while loading shared libraries: libdb-3.3.so: cannot open shared object file: No such file or directory


Expected results:

usage: svn <subcommand> [options] [args]
Subversion command-line client, version 1.4.2.
Type 'svn help <subcommand>' for help on a specific subcommand.
Type 'svn --version' to see the program version and RA modules
  or 'svn --version --quiet' to see just the version number.

Most subcommands take file and/or directory arguments, recursing
on the directories.  If no arguments are supplied to such a
command, it recurses on the current directory (inclusive) by default.

Available subcommands:
   add
   blame (praise, annotate, ann)
   cat
   checkout (co)
   cleanup
   commit (ci)
   copy (cp)
   delete (del, remove, rm)
   diff (di)
   export
   help (?, h)
   import
   info
   list (ls)
   lock
   log
   merge
   mkdir
   move (mv, rename, ren)
   propdel (pdel, pd)
   propedit (pedit, pe)
   propget (pget, pg)
   proplist (plist, pl)
   propset (pset, ps)
   resolved
   revert
   status (stat, st)
   switch (sw)
   unlock
   update (up)

Subversion is a tool for version control.
For additional information, see http://subversion.tigris.org/

Additional info:

In the x86_64 binary from package subversion-1.4.2-2.el5.x86_64, the shared library referenced in the binary is libdb-4.3.so instead of libdb-3.3.so
Comment 1 Stephen P. Schaefer 2008-09-26 17:59:30 EDT
Please close.

The problem was the LD_LIBRARY_PATH included /usr/local/lib, which contained a version of libdb-4.3.so not from RHEL5 that further referenced libdb-3.3.so
Solution: set LD_LIBRARY_PATH not to include /usr/local/lib.

Note You need to log in before you can comment on or make changes to this bug.