Bug 46426 - rpm-4.0.3-0.42 signature checking doesn't work
rpm-4.0.3-0.42 signature checking doesn't work
Status: CLOSED DUPLICATE of bug 45548
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 09:38 EDT by Peter H.S.
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 09:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H.S. 2001-06-28 09:38:29 EDT
Description of Problem:
When issuing a 'rpm -K *.rpm --nogpg' or 'rpm --checksig *.rpm --nogpg' , 
rpm gives a non expected result, instead of checking the signature of the 
rpm-archive.


How Reproducible:
Every time

Steps to Reproduce:
1. Issue a 'rpm -K PACKAGE_FILE --nogpg'

Actual Results:

The above action results in the following:
RPM version 4.0.3
Copyright (C) 1998-2000 - Red Hat, Inc.
This program may be freely redistributed under the terms of the GNU GPL
 
Usage: rpmk {--help}
       rpmk {--version}


It looks like /usr/lib/rpm/rpmk is invoked, but that it doesn't accept 
any input.



Expected Results:
rpm should have checked the signature of the rpm-package.


Additional Information:
rpm-devel-4.0.3-0.42
rpm-4.0.3-0.42
rpm-build-4.0.3-0.42
popt-1.6.3-0.42
db1-1.85-6
db1-devel-1.85-6
db2-2.4.14-6
db2-devel-2.4.14-6
db3-3.2.9-2
db3-devel-3.2.9-2
db3-utils-3.2.9-2


All important package should be up to date with Raw Hide directory.
Tried to get the rpm package from two different mirrors, in case file 
transfer corruption should be the problem. The result where the same.
Comment 1 Jeff Johnson 2001-06-28 13:05:35 EDT

*** This bug has been marked as a duplicate of 45548 ***

Note You need to log in before you can comment on or make changes to this bug.