Bug 464301 - preupgrade 0.9.3-3.fc7.noarch freezes while downloading installer stage 2
preupgrade 0.9.3-3.fc7.noarch freezes while downloading installer stage 2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
7
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 05:47 EDT by Juergen Bullinger
Modified: 2014-01-21 18:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 00:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2008-09-27 05:47:02 EDT
Description of problem:
I downloaded preupgrade yesterday (26th sepbember 2008) to upgrade my fedora 7 x86_64 System to the latest version. It seems to have downloaded all the necessary packages, but froze when it tried to download installer stage 2... and output an error message.

Version-Release number of selected component (if applicable):
I used preupgrade - 0.9.3-3.fc7.noarch (this is what the package manager says when I search for preupgrade among the installed packages)

How reproducible:
If I close the preupgrader dialog and start it again (without deleting any downloaded packages)
I get the same errormessage and the same behaviour. I tried this several times.

Steps to Reproduce:
1. download preupgrade
2. start it
3. start downloading
4. wait
  
Actual results:
It displayed "Downloading installer stage 2..." on the gui and seems to have frozen. On the console from which I started it, I got the following output:

[root@localhost tmp]# preupgrade
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 371, in main_preupgrade
    (mdev,mpath) = preupgrade.bootpath_to_anacondapath(stage2_abs)
TypeError: unpack non-sequence


Expected results:
Download everything and prompt for restart as described on the fedora page.

Additional info:
It would be nice if preupgrade could be asked to display it's version. Maybe using an about menu item or a -v option.
Comment 1 Juergen Bullinger 2008-09-27 05:50:18 EDT
Is there a Is there a possibility to resume the upgrade manually?
I already did a backup of my data and emails (bigish) and downloaded all the packages. I fear that if I can only continue after some days/weeks probably I have to do all that again :(
Comment 2 John Poelstra 2008-10-01 00:51:29 EDT
Thank you for your bug report.

We are sorry, but the Fedora Project no longer maintains this version of Fedora. Please upgrade to the latest version and reopen this bug against that version if this bug exists there.

As a result we are setting this bug to CLOSED:WONTFIX

Note You need to log in before you can comment on or make changes to this bug.