Bug 46436 - transparent proxying does not work properly
Summary: transparent proxying does not work properly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-28 16:05 UTC by Red Hat Bugzilla
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 16:05:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-06-28 16:05:27 UTC
Description of Problem:
Because of changes in the networking code of the linux 2.4 kernel over the
2.2 kernel, squid cannot tell the target web site IP address during
transparent proxying unless the browser specifies the "Host" header in the
request.

This issue has been addressed as of squid-2.4STABLE1, but the package has
to be configured with the --enable-linux-netfilter option prior
compilation.
Please make sure that you use this option when you produce a squid.2-4
update for redhat7.1 which comes with the 2.4 kernel.

Comment 1 Red Hat Bugzilla 2001-07-23 05:25:06 UTC
Current 2.4STABLE packages already have this enabled.


Note You need to log in before you can comment on or make changes to this bug.