Bug 464384 - iwl3945: Can not allocate SKB buffers
iwl3945: Can not allocate SKB buffers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 22:26 EDT by Tom London
Modified: 2008-12-19 13:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 13:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-09-27 22:26:56 EDT
Description of problem:
Saw this in /var/log/messages:

Sep 27 16:55:38 tlondon kernel: iwl3945: Can not allocate SKB buffers
Sep 27 16:55:42 tlondon kernel: iwl3945: Can not allocate SKB buffers
Sep 27 16:55:44 tlondon kernel: iwl3945: Can not allocate SKB buffers

I could detect no failures or unusual behavior, and could find no other messages.


Version-Release number of selected component (if applicable):
kernel-2.6.27-0.354.rc7.git3.fc10.i686

How reproducible:
First time I noticed it....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-10-18 13:18:44 EDT
Continue to see this on Thinkpad X61:

Oct 18 10:06:42 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 18 10:06:44 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 18 10:06:46 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 18 10:07:03 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 18 10:08:09 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 18 10:08:16 tlondon kernel: iwlagn: Can not allocate SKB buffers

Wireless is not associated, NetworkManager is running supporting "wired" connection.

03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
Comment 2 Tom London 2008-10-18 13:19:32 EDT
Oops, forgot kernel version:

kernel-2.6.27.2-23.rc1.fc10.x86_64

[Spin2]
Comment 3 John W. Linville 2008-10-27 15:00:53 EDT
I'm not sure this is really an iwlagn issue -- it is literally reporting a failure of alloc_skb.  Is your system low on memory?
Comment 4 Tom London 2008-10-27 16:25:13 EDT
2GB ThinkPad X60 and X61.  

Don't think so....  Typical top lines from 'top':

[root@tlondon ~]# top

top - 13:24:49 up  4:34,  4 users,  load average: 0.50, 0.63, 0.41
Tasks: 164 total,   2 running, 161 sleeping,   0 stopped,   1 zombie
Cpu(s):  6.5%us,  5.0%sy,  0.0%ni, 86.6%id,  1.7%wa,  0.2%hi,  0.2%si,  0.0%st
Mem:   2016320k total,  1970648k used,    45672k free,    31000k buffers
Swap:  4063224k total,      100k used,  4063124k free,   605440k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 3749 tbl       20   0  966m 537m  22m S 12.0 27.3  38:53.84 qemu-kvm           
 3585 tbl       20   0 1265m  85m  22m S  3.6  4.3   8:03.07 rhythmbox
Comment 5 Tom London 2008-10-27 16:28:03 EDT
Not 100% sure, but seems to happen frequently around supplicant changes from 6 -> 7

Oct 24 10:47:40 tlondon NetworkManager: <info>  (wlan0): supplicant connection state change: 6 -> 7
Oct 24 10:57:40 tlondon NetworkManager: <info>  (wlan0): supplicant connection state change: 7 -> 6
Oct 24 10:57:40 tlondon NetworkManager: <info>  (wlan0): supplicant connection state change: 6 -> 7
Oct 24 10:59:39 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 24 10:59:40 tlondon kernel: iwlagn: Can not allocate SKB buffers
Oct 24 11:07:40 tlondon NetworkManager: <info>  (wlan0): supplicant connection state change: 7 -> 6
Oct 24 11:07:40 tlondon NetworkManager: <info>  (wlan0): supplicant connection state change: 6 -> 7
Comment 6 Thomas Burke 2008-11-01 13:54:34 EDT
This may be related to this bug Ubuntu is tracking:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/250139

It appears to interfere with WPA and, for me, DHCPDISCOVER.
Comment 7 Tom London 2008-11-01 14:19:54 EDT
I know is sounds strange, but I think I only get these messages when I am @work and associated with an 802.1X network.

I don't think I see these when I am @home with my "vanilla WPA2" network.
Comment 8 Tom London 2008-11-16 22:23:00 EST
#7 is wrong.... I do get it @home with standard WPA2:

Nov 16 18:55:17 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:17 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:17 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:18 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:33 tlondon kernel: __ratelimit: 4228 callbacks suppressed
Nov 16 18:55:33 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:35 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:36 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:39 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:39 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:40 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:41 tlondon kernel: iwlagn: Can not allocate SKB buffers
Nov 16 18:55:43 tlondon kernel: iwlagn: Can not allocate SKB buffers

Output from "top":
top - 19:17:18 up 32 min,  3 users,  load average: 0.15, 0.31, 0.53
Tasks: 167 total,   2 running, 165 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.4%us,  1.3%sy,  0.0%ni, 94.7%id,  0.6%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2018336k total,  1897740k used,   120596k free,   411348k buffers
Swap:  4063224k total,      152k used,  4063072k free,   763680k cached

Something in particular to look for in kernel space?  slabinfo?
Comment 9 Charles R. Anderson 2008-11-17 20:10:59 EST
I happened to notice these messages from F10 Preview LiveCD *not* connected to any wireless network.  I'm doing block device copies between partitions on the hard disk using "dd" and noticed these messages scroll by the text console...

kernel-2.6.27.4-68.fc10.i686
ThinkPad T61
iwl4965

Maybe this is caused by lots of block layer activity?  I doesn't seem to happen until I start the "dd".
Comment 10 Bug Zapper 2008-11-25 22:14:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 John W. Linville 2008-12-10 14:18:37 EST
Is this still happening with current F10 kernels?
Comment 12 Tom London 2008-12-10 14:43:38 EST
I'm running rawhide (kernel-2.6.28-0.121.rc7.git5.fc11.x86_64), and yes, it is still happening.

For example:

Dec 10 07:28:21 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:28:49 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:30:16 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:30:48 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:30:50 tlondon NetworkManager: <info>  (wlan0): supplicant connection state:  completed -> group handshake
Dec 10 07:30:50 tlondon NetworkManager: <info>  (wlan0): supplicant connection state:  group handshake -> completed
Dec 10 07:30:50 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:21 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:33 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:35 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:36 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:41 tlondon kernel: iwlagn: Can not allocate SKB buffers
Dec 10 07:34:42 tlondon kernel: iwlagn: Can not allocate SKB buffers

I can get hundreds/thousands of these.
Comment 13 Tom London 2008-12-10 19:14:46 EST
Should this bug be moved back to rawhide (from 10)?  What is the process for that?
Comment 14 John W. Linville 2008-12-18 14:06:23 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=75463

The kernels being built at the link above have a patch that is supposed to address this.  Once they are build, can you confirm?
Comment 15 Tom London 2008-12-18 14:55:08 EST
OK.  I've downloaded/installed kernel-2.6.28-0.131.rc8.git4.fc11.x86_64.rpm.

Will reboot and monitor.....
Comment 16 Thomas Burke 2008-12-18 15:23:17 EST
Have not seen "SKB" in /var/log/messages since upgrading to F10. Current kernel is kernel-2.6.27.7-134.fc10.
Comment 17 Tom London 2008-12-18 19:45:33 EST
I've been running kernel-2.6.28-0.131.rc8.git4.fc11.x86_64.rpm for about 5 hours now in my "@work" wireless environment (802.1X, etc.) with NO recurrence of the "Can not allocate SKB buffers" message.

Looks good so far!

I'll continue to monitor ....

Thanks for the fix!

Note You need to log in before you can comment on or make changes to this bug.