Bug 464443 - Missing libclutter-cairo dependency
Missing libclutter-cairo dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pyclutter (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 00:56 EDT by Ben Gamari
Modified: 2008-10-01 11:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 11:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Gamari 2008-09-29 00:56:47 EDT
Description of problem:
I've been unable to install clutter-cairo ever since installing rawhide several weeks ago due to missing dependencies. Moreover, clutter needs to be badly bumped up to 0.8.2.




[0054 ben@mercury ~] $ sudo yum install clutter-cairo
Loaded plugins: allowdowngrade, changelog, downloadonly, fastestmirror, list-
              : data, merge-conf, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: fedora.bu.edu
 * rawhide-debuginfo: fedora.bu.edu
 * updates-testing: fedora.bu.edu
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libclutter-cairo-0.6.so.0()(64bit) for package: pyclutter-cairo
---> Package clutter-cairo.x86_64 0:0.8.2-1.fc10 set to be updated
--> Processing Dependency: libclutter-glx-0.8.so.0()(64bit) for package: clutter-cairo
--> Running transaction check
--> Processing Dependency: libclutter-cairo-0.6.so.0()(64bit) for package: pyclutter-cairo
---> Package clutter.x86_64 0:0.8.0-1.fc10 set to be updated
--> Processing Dependency: libclutter-glx-0.6.so.0()(64bit) for package: pyclutter-cairo
--> Processing Dependency: libclutter-glx-0.6.so.0()(64bit) for package: pyclutter
--> Finished Dependency Resolution
pyclutter-cairo-0.6.2-2.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libclutter-glx-0.6.so.0()(64bit) is needed by package pyclutter-cairo-0.6.2-2.fc10.x86_64 (installed)
pyclutter-0.6.2-2.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libclutter-glx-0.6.so.0()(64bit) is needed by package pyclutter-0.6.2-2.fc10.x86_64 (installed)
pyclutter-cairo-0.6.2-2.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libclutter-cairo-0.6.so.0()(64bit) is needed by package pyclutter-cairo-0.6.2-2.fc10.x86_64 (installed)
Error: Missing Dependency: libclutter-glx-0.6.so.0()(64bit) is needed by package pyclutter-cairo-0.6.2-2.fc10.x86_64 (installed)
Error: Missing Dependency: libclutter-glx-0.6.so.0()(64bit) is needed by package pyclutter-0.6.2-2.fc10.x86_64 (installed)
Error: Missing Dependency: libclutter-cairo-0.6.so.0()(64bit) is needed by package pyclutter-cairo-0.6.2-2.fc10.x86_64 (installed)
Comment 1 Ben Gamari 2008-09-29 01:03:18 EDT
As it turns out, the problem was actually pyclutter (although clutter is still at 0.8.0 despite clutter-cairo being at 0.8.2). pyclutter seems to be still way back at 0.6.2 and apparently depends on the now-nonexistant libclutter-glx-0.6.so. Bumping pyclutter up to 0.8.2 should fix the issue (soon if possible). Thanks.
Comment 2 Allisson Azevedo 2008-10-01 10:21:02 EDT
Hi Ben,

I'll update clutter to version 0.8.2, but, there is no version 0.8.x for pyclutter.

Note You need to log in before you can comment on or make changes to this bug.