Bug 464456 - Upstart responds to ctrl-alt-del before rc.sysinit is finished
Upstart responds to ctrl-alt-del before rc.sysinit is finished
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 04:38 EDT by Hans de Goede
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-26 14:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-29 04:38:12 EDT
Description of problem:
1) Realize you've booted the wrong kernel
2) press CTRL-ALT-DEL while udev is initializing
3) upstart starts running the halt script immediately, before rc,sysinit
   is finished, resulting in errors about / not being writable from halt

It might be that rc.sysinit and halt are running at the same time (which would be *really* bad), or it might be that rc.sysinit gets killed before its finished and then halt gets started. Either way this is not how it is supposed to work,
Comment 1 Bill Nottingham 2008-09-29 16:33:01 EDT
... would you prefer that it be ignored until after rc.sysinit? I'm not sure what behavior you want here.
Comment 2 Hans de Goede 2008-09-30 03:17:41 EDT
I want it to behave like sysvinit, so do nothing until rc.sysinit is finished, but remember that ctrl-alt-del was pressed and then when rc.sysinit is finished immediately enter runlevel 6

Which I do not want because it was what sysvinit does, but what I want because it seems the sane thing todo.
Comment 3 Casey Dahlin 2009-05-20 20:22:01 EDT
the way to do this IMHO would be to have the ctrl-alt-delete script simply wait until rc.sysinit was finished. You could do this by watching initctl events.
Comment 4 Hans de Goede 2009-05-21 06:04:40 EDT
(In reply to comment #3)
> the way to do this IMHO would be to have the ctrl-alt-delete script simply wait
> until rc.sysinit was finished. You could do this by watching initctl events.  

Or even better if possible wait with it todo anything until upstart is idle. Pressing ctrl-alt-del while a reboot  /  shutdown is already in progress leads to restarting the reboot sequence, while the old one keeps running! (or so it seems,
anyways its a mess)
Comment 5 Bill Nottingham 2010-03-26 14:49:30 EDT
I'm not really sure this is the best behavior - the idea is that when you tell it to shut down, it shuts down... in fact, I'd suspect the most often case would be to interrupt some long-running boot process that is stuck.

Note You need to log in before you can comment on or make changes to this bug.