Bug 464465 - rsh didn't close connection
rsh didn't close connection
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsh (Show other bugs)
4.9
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Tkac
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 06:00 EDT by Sergey V. Beduev
Modified: 2013-04-30 19:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 08:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Beduev 2008-09-29 06:00:10 EDT
Description of problem:
rsh didn't close connection from remote server, and process still exist in process table.

# date
Mon Sep 29 14:57:59 TMT 2008
# ps -o pid,start,ni,pri,psr,pcpu,stat,wchan:14,comm -p 14979
  PID  STARTED  NI PRI PSR %CPU STAT WCHAN          COMMAND
14979   Sep 04   0  23   0  0.0 S    -              rsh

# lsof -n -p 14979 | grep TCP
rsh     14979 root    3u  IPv4 1962395              TCP 10.0.10.1:1005->172.20.0.6:shell (FIN_WAIT2)
rsh     14979 root    5u  IPv4 1962397              TCP 10.0.10.1:1004->172.20.0.6:1023 (CLOSE_WAIT)

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-67.EL
rsh-0.17-25.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2008-10-06 07:51:35 EDT
I'm not able to reproduce this problem. Could you please specify how did you reproduced it? I tried:

- shell & login services enabled (in /etc/xinetd.d/{rsh,rlogin})
- /etc/securetty and ~/.rhosts configured properly
- run "rsh <hostname> ls"
- run "rsh <hostname>"

After that I'm not able to find any rsh process in process table.
Comment 2 Sergey V. Beduev 2009-01-19 09:11:28 EST
It's my fault. 
Please close this bug.

Note You need to log in before you can comment on or make changes to this bug.