Bug 464467 - kernel BUG at kernel/utrace.c:1649!
kernel BUG at kernel/utrace.c:1649!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 06:06 EDT by Helge Deller
Modified: 2008-10-28 11:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 11:35:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2008-09-29 06:06:37 EDT
[root@ls3313 /]# uname -a
Linux ls3313 2.6.26.3-29.fc9.i686 #1 SMP Wed Sep 3 03:42:27 EDT 2008 i686 i686 i386 GNU/Linux

Seems to be two kernel bugs, but since they happened at the same time, maybe they are related (seems it happened while I was strace-ing the winbindd process):

Sep 29 11:45:39 ls3313 kernel: ------------[ cut here ]------------
Sep 29 11:45:39 ls3313 kernel: kernel BUG at kernel/utrace.c:1649!
Sep 29 11:45:39 ls3313 kernel: invalid opcode: 0000 [#1] SMP
Sep 29 11:45:39 ls3313 kernel: Modules linked in: nfs lockd nfs_acl ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi autofs4 f
use sunrpc ip6t_REJECT xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables ipv6 loop dm_multipath i2c_piix4 sr_mod cdrom i2c_core pata_acpi
cfi_probe gen_probe dcdbas scb2_flash pata_serverworks mtd chipreg ata_generic map_funcs pcspkr tg3 libata sg floppy dm_snapshot dm_zero dm_mirror dm_log dm_mod megaraid_mbox
 megaraid_mm sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]
Sep 29 11:45:39 ls3313 kernel:
Sep 29 11:45:39 ls3313 kernel: Pid: 11721, comm: winbindd Not tainted (2.6.26.3-29.fc9.i686 #1)
Sep 29 11:45:39 ls3313 kernel: EIP: 0060:[<c045462e>] EFLAGS: 00210046 CPU: 3
Sep 29 11:45:39 ls3313 kernel: EIP is at utrace_resume+0x5d/0xdf
Sep 29 11:45:39 ls3313 kernel: EAX: f5e9d000 EBX: f6e8e2c0 ECX: 00000000 EDX: f6f2a580
Sep 29 11:45:39 ls3313 kernel: ESI: c0643784 EDI: f5e9dec8 EBP: f5e9ded4 ESP: f5e9deb8
Sep 29 11:45:39 ls3313 kernel: DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Sep 29 11:45:39 ls3313 kernel: Process winbindd (pid: 11721, ti=f5e9d000 task=f6f2a580 task.ti=f5e9d000)
Sep 29 11:45:39 ls3313 kernel: Stack: f6f2a580 00000005 00000000 00000000 0000000c bfbca424 0046cff4 f5e9dfb0
Sep 29 11:45:39 ls3313 kernel:       c0404527 00000100 f5e9dfb8 f5e9df38 c0493102 00000000 00000000 00000000
Sep 29 11:45:39 ls3313 kernel:       00000000 000cc654 f71996e8 f667a668 0100a580 f71998f0 f7199a90 00000000
Sep 29 11:45:39 ls3313 kernel: Call Trace:
Sep 29 11:45:39 ls3313 kernel: [<c0404527>] ? do_notify_resume+0x752/0x789
Sep 29 11:45:39 ls3313 kernel: [<c0493102>] ? __posix_lock_file+0x4b0/0x4ba
Sep 29 11:45:39 ls3313 kernel: [<c0492431>] ? locks_free_lock+0x3d/0x40
Sep 29 11:45:39 ls3313 kernel: [<c049335e>] ? fcntl_setlk64+0x242/0x24c
Sep 29 11:45:39 ls3313 kernel: [<c048fd1a>] ? sys_fcntl64+0x71/0x7b
Sep 29 11:45:39 ls3313 kernel: [<c0404d00>] ? work_notifysig+0x13/0x1b
Sep 29 11:45:39 ls3313 kernel: [<c0630000>] ? __down_interruptible+0x4/0x8d
Sep 29 11:45:39 ls3313 kernel: =======================
Sep 29 11:45:39 ls3313 kernel: Code: 43 18 88 c2 83 e0 02 83 e2 f7 88 53 18 f0 fe 43 10 84 c0 0f 84 8c 00 00 00 f6 43 18 04 74 10 8b 55 e4 8b 42 04 f6 40 08 02 75 7a <0f> 0b
eb fe 89 d8 e8 63 ed ff ff 8b 4b 08 8d 7b 08 8b 31 eb 15
Sep 29 11:45:39 ls3313 kernel: EIP: [<c045462e>] utrace_resume+0x5d/0xdf SS:ESP 0068:f5e9deb8
Sep 29 11:45:39 ls3313 kernel: ---[ end trace 18ecbe207f249d84 ]---
Sep 29 11:45:39 ls3313 kernel: BUG: sleeping function called from invalid context at kernel/rwsem.c:21
Sep 29 11:45:39 ls3313 kernel: in_atomic():0, irqs_disabled():1
Sep 29 11:45:39 ls3313 kernel: Pid: 11721, comm: winbindd Tainted: G      D   2.6.26.3-29.fc9.i686 #1
Sep 29 11:45:39 ls3313 kernel: [<c04213ea>] __might_sleep+0xae/0xb3
Sep 29 11:45:39 ls3313 kernel: [<c062ff56>] down_read+0x15/0x29
Sep 29 11:45:39 ls3313 kernel: [<c044d684>] acct_collect+0x37/0x15d
Sep 29 11:45:39 ls3313 kernel: [<c042ba34>] do_exit+0x1a2/0x71a
Sep 29 11:45:39 ls3313 kernel: [<c062ecaa>] ? printk+0xf/0x15
Sep 29 11:45:39 ls3313 kernel: [<c0428b24>] ? oops_exit+0x23/0x28
Sep 29 11:45:39 ls3313 kernel: [<c0406190>] die+0x15c/0x164
Sep 29 11:45:39 ls3313 kernel: [<c0631657>] do_trap+0x8a/0xa3
Sep 29 11:45:39 ls3313 kernel: [<c0406584>] ? do_invalid_op+0x0/0x76
Sep 29 11:45:39 ls3313 kernel: [<c04065f0>] do_invalid_op+0x6c/0x76
Sep 29 11:45:39 ls3313 kernel: [<c045462e>] ? utrace_resume+0x5d/0xdf
Sep 29 11:45:39 ls3313 kernel: [<c04f5e61>] ? __next_cpu+0x15/0x25
Sep 29 11:45:39 ls3313 kernel: [<c041eaca>] ? find_busiest_group+0x23f/0x5d3
Sep 29 11:45:39 ls3313 kernel: [<c0630f92>] error_code+0x72/0x78
Sep 29 11:45:39 ls3313 kernel: [<c045462e>] ? utrace_resume+0x5d/0xdf
Sep 29 11:45:39 ls3313 kernel: [<c0404527>] do_notify_resume+0x752/0x789
Sep 29 11:45:39 ls3313 kernel: [<c0493102>] ? __posix_lock_file+0x4b0/0x4ba
Sep 29 11:45:39 ls3313 kernel: [<c0492431>] ? locks_free_lock+0x3d/0x40
Sep 29 11:45:39 ls3313 kernel: [<c049335e>] ? fcntl_setlk64+0x242/0x24c
Sep 29 11:45:39 ls3313 kernel: [<c048fd1a>] ? sys_fcntl64+0x71/0x7b
Sep 29 11:45:39 ls3313 kernel: [<c0404d00>] work_notifysig+0x13/0x1b
Sep 29 11:45:39 ls3313 kernel: [<c0630000>] ? __down_interruptible+0x4/0x8d
Sep 29 11:45:39 ls3313 kernel: =======================
Comment 1 Roland McGrath 2008-09-30 01:01:22 EDT
I think this bug is fixed in the rawhide kernel.
Comment 2 Chuck Ebbert 2008-10-23 22:37:53 EDT
Please test kernel-2.6.26.6-79.fc9
Comment 3 Helge Deller 2008-10-24 11:27:46 EDT
I was running kernel-2.6.26.5-45.fc9.i686 since Oct 9th, and there was no problem yet (although the machine wasn't much used).
Now I installed kernel-2.6.26.6-79.fc9, let's see how it works.
Maybe you just close the bug now, I'll reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.