Bug 464564 - Test for ldap.h in ipa-server/configure
Test for ldap.h in ipa-server/configure
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: build (Show other bugs)
2.0
All Linux
low Severity medium
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 431020
  Show dependency treegraph
 
Reported: 2008-09-29 11:55 EDT by Rob Crittenden
Modified: 2015-01-04 18:34 EST (History)
3 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 05:31:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2008-09-29 11:55:33 EDT
Description of problem:

We need to add a configure test for configure.h so that the test for dirsrv/slapi-plugin.h compiles.

This needs to be done in the context of openldap vs mozldap so we can test for the appropriate header.

Version-Release number of selected component (if applicable):

GIT tip as of 09/29/2008 

9b8f7b1eac4edcca3ecdf6e4f15f1a9857e78172
Comment 1 Rob Crittenden 2008-09-29 11:59:21 EDT
Rich M. clarified that this requires the mozldap ldap.h and that it isn't compatible with openldap.

It looks like the tests are out-of-order in configure.ac
Comment 4 Rob Crittenden 2010-09-14 12:36:38 EDT
ticket https://fedorahosted.org/freeipa/ticket/221
Comment 5 Rob Crittenden 2011-03-10 22:11:40 EST
Fixed in v2

master: ceb91a3f7175307e4fbae929e98063fba8cc9123

Note You need to log in before you can comment on or make changes to this bug.