Bug 46461 - rage-128 text corruption bug still present
rage-128 text corruption bug still present
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 17:25 EDT by Timothy Hamlin
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 17:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Hamlin 2001-06-28 17:25:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.7 i686)

Description of problem:
There is a MAJOR text corruption problem with XF86-SVGA for the rage-128
chipsets, it has been present at least since the initial release of rh6.2
with XFree86-3.3.6-x.  There is a fix for it
(ftp.xfree86.org/XFree86/3.3.6/fixes/fix-01-r128), or so the fix claims. 
Lines of text often do not appear (and only becomes visible upon selecting
the blank area with a mouse) and text is frequently placed incorrectly,
i.e., output of 'ls' in an xterm appears in upper left corner of display,
rather than upper left corner of xterm.  With great hope, I updated to
XFree86-SVGA-3.3.6-29, which is the latest update available for rh6.2, the
problem is still there...Can we get a new one built with this patch made? 
Please please please...Also, is redhat going to release XFree86 4.0.x under
the 6.2 distribution (glibc_2.1)?  This, too, resolves the problem.  I have
the rage-128 card in several machines, and it works fine in 4.0.x XFree
envs., but is horrible in 3.3.6-x.


How reproducible:
Always

Steps to Reproduce:
1.buy a PC
2.install an ATI rage-128 card, install redhat-6.2, upgrade to all the
latest software
3.run X, text is all over the place...ahhhhhhh!
	

Actual Results:  I got pissed off and sent this bug report, to plead for an
official rh6.2 release with this bug patched.

Additional info:
Comment 1 Mike A. Harris 2001-07-16 02:47:08 EDT
The patch you speak of AFAIR is integrated into the XFree86 sources already.
There will definitely not be a release of XFree86 4.anything for anything
less than Red Hat Linux 7.0.

Please upgrade to our current release for the best R128 support.

Note You need to log in before you can comment on or make changes to this bug.