Bug 464612 - SELinux is preventing access to files with the label, file_t. Target Objects:  ./keyboard [ file ] Source:  rhgb
SELinux is preventing access to files with the label, file_t. Target Objects:...
Status: CLOSED DUPLICATE of bug 463785
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.3
All Linux
medium Severity medium
: beta
: ---
Assigned To: Daniel Walsh
BaseOS QE
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 14:14 EDT by Suzanne Hillman
Modified: 2008-09-29 14:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 14:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-09-29 14:14:17 EDT
Description of problem:
SELinux is preventing access to files with the label, file_t. 

Target Objects:  ./keyboard [ file ]  
Source:  rhgb

Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-158.el5
rhgb-0.16.4-8.el5

How reproducible:
Unclear
  
-------------

Summary:

SELinux is preventing access to files with the label, file_t.

Detailed Description:

SELinux permission checks on files labeled file_t are being denied. file_t is
the context the SELinux kernel gives to files that do not have a label. This
indicates a serious labeling problem. No files on an SELinux box should ever be
labeled file_t. If you have just added a new disk drive to the system you can
relabel it using the restorecon command. Otherwise you should relabel the entire
files system.

Allowing Access:

You can execute the following command as root to relabel your computer system:
"touch /.autorelabel; reboot"

Additional Information:

Source Context                system_u:system_r:rhgb_t:s0
Target Context                system_u:object_r:file_t:s0
Target Objects                ./keyboard [ file ]
Source                        rhgb
Source Path                   <Unknown>
Port                          <Unknown>
Host                          dhcp-100-2-166.bos.redhat.com
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-2.4.6-158.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   file
Host Name                     dhcp-100-2-166.bos.redhat.com
Platform                      Linux dhcp-100-2-166.bos.redhat.com 2.6.18-116.el5
                              #1 SMP Thu Sep 18 18:12:38 EDT 2008 i686 i686
Alert Count                   80
First Seen                    Wed 24 Sep 2008 02:08:26 PM EDT
Last Seen                     Mon 29 Sep 2008 10:03:33 AM EDT
Local ID                      9387db21-f259-46bb-829f-61c943796cb4
Line Numbers                  

Raw Audit Messages            

host=dhcp-100-2-166.bos.redhat.com type=AVC msg=audit(1222697013.986:25): avc:  denied  { read } for  pid=1943 comm="rhgb" name="keyboard" dev=dm-0 ino=2686991 scontext=system_u:system_r:rhgb_t:s0 tcontext=system_u:object_r:file_t:s0 tclass=file
Comment 1 Radek Bíba 2008-09-29 14:38:35 EDT
Looks like a dupe of bug 463785 to me.
Comment 2 Suzanne Hillman 2008-09-29 14:46:26 EDT
Agreed. Sorry! Hadn't found that one.

*** This bug has been marked as a duplicate of bug 463785 ***

Note You need to log in before you can comment on or make changes to this bug.