Bug 464635 - perl-Term-ReadLine-Gnu fails to initialize
perl-Term-ReadLine-Gnu fails to initialize
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: perl-Term-ReadLine-Gnu (Show other bugs)
el5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 15:13 EDT by b.candler
Modified: 2008-09-30 03:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 03:25:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of Term::ReadLine invocation (79.43 KB, text/plain)
2008-09-30 03:18 EDT, b.candler
no flags Details

  None (edit)
Description b.candler 2008-09-29 15:13:29 EDT
Description of problem:

perl-Term-ReadLine-Gnu doesn't seem to work correctly at all under CentOS 5.
(Initial symptoms detected when trying yasql, but recipe below shows how to replicate)

Version-Release number of selected component (if applicable):
perl-Term-ReadLine-Gnu-1.17a-2.el5.i386.rpm

How reproducible: Completely


Steps to Reproduce:
1. Install CentOS 5, yum install perl-Term-ReadLine-Gnu
2. $ perl -MTerm::ReadLine -e 'new Term::ReadLine("test")'
  
Actual results: Cannot do `initialize' in Term::ReadLine::Gnu at -e line 1


Expected results: Blank (Object should be created successfully)


Additional info:
Possibly a known problem, but I can't find the solution.
http://markmail.org/message/ycvyuf6zjies7amn
Comment 1 Lubomir Rintel 2008-09-29 16:44:07 EDT
Thanks for the report. I'm not able to reproduce this (same version, on CentOS), and therefore don't have much clue where to start to.

Which terminal do you use?

Could you please run the following command and attach the "log" file to this bug report, so I can compare what's different in the way the package works on your system compared to mine?

strace -f -o log perl -MTerm::ReadLine -e 'new Term::ReadLine("test")'

Thanks
Comment 2 b.candler 2008-09-30 03:18:44 EDT
Created attachment 318044 [details]
strace of Term::ReadLine invocation
Comment 3 b.candler 2008-09-30 03:25:59 EDT
Thank you. strace shows it failing looking for Term::ReadLine::Perl

Doing a 'locate', I see I have an old version /usr/lib/perl5/site_perl/5.8.5/Term/ReadLine/Perl.pm which is not owned by any package.

I zapped the 5.8.5 directory and now the module is working fine.

Please close the ticket, and I apologise for the dumb report.

Regards,

Brian.

Note You need to log in before you can comment on or make changes to this bug.