Bug 464692 - firefox 2.0.0.17-1 crashes in PL_DHashTableOperate()
firefox 2.0.0.17-1 crashes in PL_DHashTableOperate()
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
All Linux
high Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 17:53 EDT by Christophe GRENIER
Modified: 2008-09-30 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 07:56:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output (9.57 KB, text/plain)
2008-09-29 17:53 EDT, Christophe GRENIER
no flags Details

  None (edit)
Description Christophe GRENIER 2008-09-29 17:53:09 EDT
Created attachment 318011 [details]
gdb output

Description of problem:
firefox 2.0.0.17-1 crashes in PL_DHashTableOperate(), pldhash.c, when visiting some sites.

Version-Release number of selected component (if applicable):
firefox-2.0.0.17-1.fc8.x86_64
flash-plugin-9.0.124.0-release.i386
java-1.7.0-icedtea-plugin-1.7.0.0-0.20.b21.snapshot.fc8.x86_64
libflashsupport-000-0.1.svn20070904.i386
libflashsupport-000-0.1.svn20070904.x86_64
nspluginwrapper-0.9.91.5-18.fc8.i386
nspluginwrapper-0.9.91.5-18.fc8.x86_64
totem-mozplugin-2.20.1-2.fc8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2. Go to https://bugzilla.redhat.com
  
Actual results:
It crashes

Expected results:
Page displayed

Additional info:
Downgrading to firefox-2.0.0.16-1.fc8.x86_64 seems to solve the issue.
Comment 1 Martin Stransky 2008-09-30 03:18:19 EDT
Hm, I can't reproduce it on f8/i386, it may be x86_64 specific... 

Can you please try to run it in safe mode? (firefox -safe-mode)
Comment 2 Martin Stransky 2008-09-30 03:43:10 EDT
Kay, those null pointers don't look sane...any thoughts?

#0  PL_DHashTableOperate (table=0x0, key=0x40c88c00, op=PL_DHASH_LOOKUP) at pldhash.c:547
        keyHash = <value optimized out>
        entry = <value optimized out>
        size = <value optimized out>
#1  0x000000000086319b in nsCStringHashSetSuper::GetEntry (this=0x0, aKey=@0x40c88c00) at nsHashSets.cpp:44
        e = <value optimized out>
#2  0x00007f0cba9c66af in nsSSLIOLayerHelpers::isKnownAsIntolerantSite (str=@0x40c88c00)
    at ../../../../dist/include/xpcom/nsHashSets.h:99
Comment 3 Christophe GRENIER 2008-09-30 07:34:53 EDT
When using "firefox -safe-mode", firefox doesn't crash anymore.
I have restarted firefox without parameter, disabling another extension each time until firefox doesn't crash.
The culprit (maybe only the trigger) was FoxyProxy, a 100% javascript extension. This morning, version 2.8.8 was available, since the update, no crash has occurred. I haven't found any changelog about the new version.

It seems the problem has been reported on foxyproxy web site a few days ago:
http://foxyproxy.mozdev.org/drupal/content/foxyproxy-crashes-firefox-20017
Comment 4 Martin Stransky 2008-09-30 07:56:48 EDT
Okay, thanks for the info, closing.

Note You need to log in before you can comment on or make changes to this bug.