Bug 464727 - includes its own copy of python-simplejson rather than using the system copy
includes its own copy of python-simplejson rather than using the system copy
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Weller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 21:51 EDT by Jeremy Katz
Modified: 2008-10-30 08:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 08:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick and dirty patch (6.54 KB, patch)
2008-10-02 21:46 EDT, Jeremy Katz
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2008-09-29 21:51:37 EDT
gwibber includes its own copy of python-simplejson rather than depending on and using the system copy.  This was (sort of) okay when the versions were the same, but the version in Fedora has been updated now and has API changes leading to tracebacks.
Comment 1 Fedora Update System 2008-09-30 00:46:18 EDT
gwibber-0.7-5.102bzr.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gwibber-0.7-5.102bzr.fc9
Comment 2 Fedora Update System 2008-09-30 00:46:27 EDT
gwibber-0.7-5.102bzr.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/gwibber-0.7-5.102bzr.fc8
Comment 3 Fedora Update System 2008-10-01 02:35:07 EDT
gwibber-0.7-5.102bzr.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8466
Comment 4 Fedora Update System 2008-10-01 02:39:12 EDT
gwibber-0.7-5.102bzr.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8481
Comment 5 Jeremy Katz 2008-10-01 16:08:48 EDT
gwibber-0.7-5.102bzr.fc10.noarch still has its own copy of python-simplejson which is still incompatible with the system version -- which leads to tracebacks like the following

[katzj@aglarond Desktop]$ gwibber 
<gwibber.config.Account instance at 0x8ffb7ac> Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/__init__.py", line 32, in get_message_data
    for message in client.get_messages():
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/twitter.py", line 64, in get_messages
    for data in self.get_data():
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/twitter.py", line 60, in get_data
    return support.simplejson.loads(self.connect(
AttributeError: 'module' object has no attribute 'simplejson'
Failed to retrieve messages
<gwibber.config.Account instance at 0x8ffbaac> Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/__init__.py", line 32, in get_message_data
    for message in client.get_messages():
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/identica.py", line 64, in get_messages
    for data in self.get_data():
  File "/usr/lib/python2.5/site-packages/gwibber/microblog/identica.py", line 60, in get_data
    return support.simplejson.loads(self.connect(
AttributeError: 'module' object has no attribute 'simplejson'
Failed to retrieve messages
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.5/threading.py", line 446, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.5/site-packages/gwibber/client.py", line 680, in process
    for message in data: self.content.add(message)
  File "/usr/lib/python2.5/site-packages/gwibber/gwui.py", line 39, in add
    self.execute_script("addMessage(%s)" % microblog.support.simplejson.dumps(
AttributeError: 'module' object has no attribute 'simplejson'
Comment 6 Ian Weller 2008-10-02 20:54:27 EDT
I noticed that rawhide has bumped up to version 2.0.1. I've alerted the developer, and I'll most likely take a look at it myself when I find the time.
Comment 7 Jeremy Katz 2008-10-02 21:40:47 EDT
The right answer is really that it should not be including its own copy of python-simplejson.  It's directly analagous to C apps which include their own copies of a library rather than using a system one, which is explicitly called out as disallowed in the packaging guidelines because it leads to lots of problems with symbol collisions (like this), security updates, etc.

And FWIW, the quick and dirty hack of removing the microblog/support/simplejson directory and updating places which were using it to instead use the system python-simplejson is working just fine now in a quick test with twitter+identica
Comment 8 Jeremy Katz 2008-10-02 21:46:15 EDT
Created attachment 319310 [details]
quick and dirty patch

Quick and dirty patch that should do the trick -- this plus doing 'rm -rf gwibber/microblog/simplejson' in %setup and it should be equivalent to what I'm running with direct editing.
Comment 9 Fedora Update System 2008-10-30 08:53:15 EDT
gwibber-0.7-5.102bzr.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.