Bug 464808 - channel.software.listAllPackages & listAllPackagesByDate list date arguments as date objects
channel.software.listAllPackages & listAllPackagesByDate list date arguments...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
John Matthews
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2008-09-30 11:59 EDT by Justin Sherrill
Modified: 2009-09-10 15:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-09-30 11:59:22 EDT
In the api documentation, both sets of these calls say they use dateTime.iso8601 as their arguments.  But if you check the java code, they actually take strings.
Comment 1 Brad Buckingham 2009-02-10 16:01:23 EST
Modifications made with git commit:
2fea30f4265d0ff28ff66febee6f4e87e7fed140


If we change the java code to use Date instead of String, it will change the current input that a user must provide.

In order to address maintain backward compatibility in the current release, performed the following:

- created listAllPackages(String sessionKey, String channelLabel, Date startDate,
                          Date endDate)

- created listAllPackages(String sessionKey, String channelLabel, Date startDate)

- deprecated listAllPackages(String sessionKey, String channelLabel, 
                             String startDate, String endDate)

- deprecated listAllPackages(String sessionKey, String channelLabel,
                             String startDate)

- since the listAllPackagesByDate APIs were marked as 'deprecated' by BZ 464807, left the API parameter types as String for start/endDate but modified the API doc to list these as "string" parameters.
Comment 2 John Matthews 2009-02-17 12:43:09 EST
Verified with Satellite-5.3.0-RHEL5-re20090213.1-i386-embedded-oracle.iso
Comment 3 Milan Zazrivec 2009-08-13 05:57:15 EDT
Verified in stage -> RELEASE_PENDING
Comment 4 Brandon Perkins 2009-09-10 15:53:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.