Bug 464833 - control-center update has trouble parsing default gconf values
control-center update has trouble parsing default gconf values
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 14:48 EDT by Michal Jaegermann
Modified: 2008-09-30 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 19:23:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-09-30 14:48:35 EDT
Description of problem:

A part of package scripts looks like follows:

export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule \
        /etc/gconf/schemas/control-center.schemas > /dev/null

When running that, during an update or "stand-alone" the following
shows up:

WARNING: Failed to parse default value `கருப்பொருளை மாற்று ;gtk-theme-selector.desktop,முன்னிருப்பு பயன்பாடுகள் அமை;default-applications.desktop,அச்சுப்பொறி சேர்;gnome-cups-manager.desktop]' for schema (/schemas/apps/control-center/cc_actions_list)

Unexpected encoding?  When redirected to xxd the beginning of this
message comes up like that:

0000000: 5741 524e 494e 473a 2046 6169 6c65 6420  WARNING: Failed
0000010: 746f 2070 6172 7365 2064 6566 6175 6c74  to parse default
0000020: 2076 616c 7565 2060 e0ae 95e0 aeb0 e0af   value `........
0000030: 81e0 aeaa e0af 8de0 aeaa e0af 8ae0 aeb0  ................
0000040: e0af 81e0 aeb3 e0af 8820 e0ae aee0 aebe  ......... ......
0000050: e0ae b1e0 af8d e0ae b1e0 af81 203b 6774  ............ ;gt
0000060: 6b2d 7468 656d 652d 7365 6c65 6374 6f72  k-theme-selector
0000070: 2e64 6573 6b74 6f70 2ce0 aeae e0af 81e0  .desktop,.......
0000080: aea9 e0af 8de0 aea9 e0ae bfe0 aeb0 e0af  ................
....
and so on.

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-1.fc10

How reproducible:
always
Comment 1 Matthias Clasen 2008-09-30 19:23:51 EDT
fixed in 2.24.0.1-2.fc10

Note You need to log in before you can comment on or make changes to this bug.