Bug 464872 - system.listGroups returns 'subscribed' as string
system.listGroups returns 'subscribed' as string
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Justin Sherrill
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2008-09-30 18:29 EDT by Justin Sherrill
Modified: 2009-08-13 16:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 16:52:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-09-30 18:29:44 EDT
This is a 1 or 0 value and is documented as an Int.  It should not be a string!
Comment 1 Brad Buckingham 2009-02-10 16:52:02 EST
Just ran a quick test on space05 and looks like this may have already been fixed.  Closing as 'not a bug'.


>>> client.system.listGroups(key,1000010108)
[{'sgid': '109', 'subscribed': 0, 'id': 109, 'system_group_name': 'bradgroup'}, {'sgid': '84', 'subscribed': 0, 'id': 84, 'system_group_name': 'ManagedGrouplHAvwRe9xnKwb'}, {'sgid': '85', 'subscribed': 0, 'id': 85, 'system_group_name': 'ManagedGroupqo94I3N0y5W1o'}]
>>>
Comment 2 Sayli Karmarkar 2009-08-13 16:03:38 EDT
>>> server.system.listGroups(key, 1000013080)
[{'sgid': '1467', 'system_group_name': 'foobar', 'subscribed': 1, 'id': 1467}]

ClosedValid.

Note You need to log in before you can comment on or make changes to this bug.