Bug 464935 - Intel Wireless Link 5100/5300 not supported in fc9 kernel
Intel Wireless Link 5100/5300 not supported in fc9 kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 10:57 EDT by Lukas Tvrdy
Modified: 2008-10-07 13:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 13:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Tvrdy 2008-10-01 10:57:45 EDT
Description of problem:
Kernel 2.6.26.3 did not recognize Intel Wireless Link 5100 card

According this announce [1] the support should be shipped with actual Fedora 9 kernels.

[1] http://linux.derkeiler.com/Mailing-Lists/Kernel/2008-08/msg05976.html

Version-Release number of selected component (if applicable):
kernel 2.6.26.3-29.fc9.i686

I tested also this kernel:
http://koji.fedoraproject.org/koji/buildinfo?buildID=63641

How reproducible:
It do not work at all -- hardware is not recognized.

Steps to Reproduce:
iwconfig should identify the wifi card
lspci should identify the device - Intel has provided 

"..pci.ids were already sent to http://pciids.sourceforge.net"

 
Actual results:
lspci | grep Network
02:00.0 Network controller: Intel Corporation Unknown device 4237


Expected results:
4237 Wifi Link 5100 Wireless Adapter
iwconfig shows wlan0 or something like that


Additional info:
More information about the problem is here:
http://forums.fedoraforum.org/showthread.php?t=200440

Speculation:
missing iwlagn.ko?
locate iwlagn.ko should return that the kernel module is present
modprobe iwlagn
iwconfig than should return some wifi device?
Comment 1 Dave Jones 2008-10-01 19:10:13 EDT
the iwlagn driver didn't get merged in 2.6.26
It won't show up in F-9 until after 2.6.27 is released, and then backported as an update.

The lspci text is nothing to do with the kernel, file a separate bug against pciutils for that one.
Comment 2 Lukas Tvrdy 2008-10-03 07:03:02 EDT
Today I tested FC10 beta,KDE Live CD and the card was not detected automatically.
I had to do modprobe iwlagn. Then the iwconfig shows the wifi card as wlan0.

ifup wlan0 did not work.

Tested kernel: kernel-2.6.27-0.352.rc7.git1.fc10.i686 (from KDE Live CD)

Here is the lspci bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=465440

I would like to resolve this as I want working wifi in FC10.
I will show up in #fedora-devel, or where I can talk about it?
Comment 3 John W. Linville 2008-10-03 10:44:10 EDT
Did you install the firmware?
Comment 4 Lukas Tvrdy 2008-10-03 16:59:41 EDT
Yep, I installed firmware called iwl5000-firmware with yum.
I probably managed to wake up the wifi. But scanning was not sucessful.
I did iwlist wlan0 scan and no wifi were found, even there are 3 or 4 around.
Comment 5 Lukas Tvrdy 2008-10-07 13:31:13 EDT
Today I get working wifi. I installed kernel from rawhide into FC9 without one depenedency -- mkinitrd.i386.

I installed
kernel-2.6.27-0.392.rc8.git7.fc10.i686
kernel-firmware-2.6.27-0.392.rc8.git7.fc10.noarch

Before that I removed firmware called iwl4965-firmware.
Now I got working Intel Wifi Link 5100.

Resolved for me!
Comment 6 John W. Linville 2008-10-07 13:35:30 EDT
Excellent! :-)

Note You need to log in before you can comment on or make changes to this bug.