Bug 465021 - [RHEL5.3] init [FAILED] messages, error: "Operation not permitted" while booting normally
[RHEL5.3] init [FAILED] messages, error: "Operation not permitted" while boot...
Status: CLOSED DUPLICATE of bug 463659
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 12:04 EDT by Jeff Burke
Modified: 2008-10-02 13:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 13:21:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-10-01 12:04:55 EDT
Description of problem:
 Numerous [FAILED] messages while booting a fresh install of RHEL5.3-Server-20080930.0

<snip>
error: "Operation not permitted" reading key "net.ipv6.conf.lo.accept_dad"
error: "Operation not permitted" reading key "net.ipv6.conf.lo.disable_ipv6"

Starting system message bus: Failed to start message bus: Could not get UID and GID for username "dbus"

Starting Avahi daemon... [FAILED]
Starting HAL daemon: [FAILED]
</snip>

Version-Release number of selected component (if applicable):
 RHEL5.3-Server-20080930.0

How reproducible:
 Always

Steps to Reproduce:
1. Install RHEL5.3-Server-20080930.0
  
Actual results:

.
.
.
Setting up Logical Volume Management:   2 logical volume(s) in volume group "VolGroup00" now active
[  OK  ]
Checking filesystems
Checking all file systems.
[/sbin/fsck.ext3 (1) -- /] fsck.ext3 -a /dev/VolGroup00/LogVol00 
/dev/VolGroup00/LogVol00: clean, 69536/52756480 files, 2175058/52740096 blocks
[/sbin/fsck.ext3 (1) -- /boot] fsck.ext3 -a /dev/sda1 
/boot: clean, 33/26104 files, 15680/104388 blocks
[  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]
Mounting local filesystems:  [  OK  ]
Enabling local filesystem quotas:  [  OK  ]
Enabling /etc/fstab swaps:  [  OK  ]
INIT: Entering runlevel: 3
Entering non-interactive startup
Applying Intel CPU microcode update: [  OK  ]
Starting monitoring for VG VolGroup00:   2 logical volume(s) in volume group "VolGroup00" monitored
[  OK  ]
Starting background readahead: [  OK  ]
Checking for hardware changes [  OK  ]
Enabling ondemand cpu frequency scaling: [  OK  ]
error: "Operation not permitted" reading key "net.ipv6.conf.lo.accept_dad"
error: "Operation not permitted" reading key "net.ipv6.conf.lo.disable_ipv6"
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... done.
[  OK  ]
Starting auditd: [  OK  ]
Starting restorecond: [  OK  ]
Starting system logger: [  OK  ]
Starting kernel logger: [  OK  ]
Starting irqbalance: [  OK  ]
Starting portmap: [  OK  ]
Starting NFS statd: [  OK  ]
Starting RPC idmapd: [  OK  ]
Starting system message bus: Failed to start message bus: Could not get UID and GID for username "dbus"
[FAILED]
[  OK  ] Bluetooth services:[  OK  ]
Mounting other filesystems:  [  OK  ]
Starting PC/SC smart card daemon (pcscd): [  OK  ]
Starting hidd: [  OK  ]
Starting autofs:  Loading autofs4: [  OK  ]
Starting automount: [  OK  ]
[  OK  ]
Starting acpi daemon: [  OK  ]
Generating SSH1 RSA host key: [  OK  ]
Generating SSH2 RSA host key: [  OK  ]
Generating SSH2 DSA host key: [  OK  ]
Starting sshd: [  OK  ]
Starting cups: [  OK  ]
ntpd: Synchronizing with time server: [  OK  ]
Starting ntpd: [  OK  ]
Starting sendmail: [  OK  ]
Starting sm-client: [  OK  ]
Starting console mouse services: [  OK  ]
Starting crond: [  OK  ]
Starting xfs: [  OK  ]
Starting anacron: [  OK  ]
Starting atd: [  OK  ]
Starting yum-updatesd: [  OK  ]
Starting Avahi daemon... [FAILED]
Starting HAL daemon: [FAILED]

Expected results:
System should start clean

Additional info:
Some of these I have seen since the 20080814 tree
Comment 1 Bill Nottingham 2008-10-01 17:03:12 EDT
If the kernel isn't allowing the reading of that key, that sounds like a kernel issue.
Comment 2 Jeff Burke 2008-10-01 17:47:55 EDT
Bill,
  What about the other messages?
Comment 3 Bill Nottingham 2008-10-01 22:17:37 EDT
avahi and hal fail because dbus fails. dbus not being able to get its uid/gid implies an installation issue with the dbus package.

Note You need to log in before you can comment on or make changes to this bug.