Bug 465094 - user.setDefaultServerGroup(s) throws error if target user isn't an admin of the group
user.setDefaultServerGroup(s) throws error if target user isn't an admin of t...
Status: CLOSED DUPLICATE of bug 470336
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
John Matthews
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2008-10-01 12:40 EDT by Justin Sherrill
Modified: 2009-08-14 16:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 11:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-10-01 12:40:37 EDT
if you call user.addDefaultServerGroup and pass a user and a group, where the user isn't the admin of the group you get an error. 

However, the UI allows this and there is not reason why the api shouldn't.  The user doesn't have to be an admin of a group to have that group be a default group for him.
Comment 1 Brad Buckingham 2009-02-11 08:48:19 EST
I ran a couple of tests using space05 and so far have not been able to reproduce the problem.

Running the API as Satellite Admin, I'm able add a default group to a user regardless of whether or not that user is an admin of the group.

e.g.

>>> client.user.addDefaultSystemGroup(key,'bbuckingham', 'bradgroup')
1

>>> client.user.addDefaultSystemGroup(key,'bbuckingham', 'bradgroup2')
1


Justin, 
Can you provide more details on the scenario that you observed this error?
Comment 2 Brad Buckingham 2009-02-17 11:58:53 EST
After discussion with Justin, we found that this BZ is actually a duplicate of bug 470336.

*** This bug has been marked as a duplicate of bug 470336 ***

Note You need to log in before you can comment on or make changes to this bug.