Bug 465129 - Fedora 9 netinst text fails to install
Fedora 9 netinst text fails to install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 14:22 EDT by David A. Bandel
Modified: 2008-10-03 07:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 07:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Bandel 2008-10-01 14:22:32 EDT
Description of problem:
d/l netinst.iso and burned to CD.  Booting up, chose text mode install from grub menu.  Refuses to continue -- doesn't recognize Fedora install CD.

mounted ISO in server /tftpboot directory.  linked Apache to mount. booted from vmlinuz/initrd.img using PXE/TFTP.  Got "Welcome to Fedora" screen (and screen telling me insufficient memory for graphical install, continuing w/ text install) and several screens thereafter.  Told me it couldn't find images/minstg2.img (probably because the only file there is images/stage2.img).

Copied stage2.img to server as minstg2.img.  Install continued until after disk partitioning, then install failed to find the metadata file (repo???.xml).  Could only exit after that (edit not available under text install).

Version-Release number of selected component (if applicable):
Fedora 9 i386 netinst.iso from Fedora download site.

How reproducible:
Try netinst.iso w/ text install (using PXE/TFT boot and installing components in web server).

Steps to Reproduce:
see above -- if further details needed, contact me.
1.
2.
3.
  
Actual results:
No install after disk partitioned.

Expected results:
Fedora 9 installation.

Additional info: (like, besides that the install failed? ;-) ).
Comment 1 Chris Lumens 2008-10-01 14:38:23 EDT
Is this still an issue with F10 beta?
Comment 2 David A. Bandel 2008-10-01 20:55:04 EDT
Well, I still can't get an install out of F10 Beta netinst.iso.

This time, I'm not getting to the partitioner, anaconda is dying during module load.  The four FATALs on F3 are (not in order): jbd, aes, crypto_blkcipher, and dm_mod not found (and the install stops).

Couple of notes:
1.  had to add askmethod to the pxelinux.cfg/default file or anaconda just kept looking for a non-existent CD-ROM.
2.  the network config asks if I want ipv4 and ipv6.  I answer yes to both.  I provide the hostname for the URL.  Can't find the file install.img.  I remove the hostname, put in ipv4 decimal dotted notation address and it loads the file just fine.  If anaconda wget can't handle IPv6 addresses, why is it requesting AAAA RR from my DNS server (tole.pananix.com has both AAAA and A RRs).  Anaconda should only request A RRs if it chokes when provided AAAA RRs.
3.  This test box has 256M RAM.  I had to play with the FB and shared mem memory options in BIOS to get this to run in text mode (where did this option go?).  First time, it crashed because I only had about 192Mb of memory available and it ran out of memory and killed the network manager (not a good idea on a network install) and that stopped the install.  Next time I had too much RAM and it tried to start a GUI and the GUI startup failed and I had _nothing_ on the screen.  Need to put the text option back.  This box will never have a monitor, keyboard, or GUI once installed.  Will do nothing but sniff packets.

A tftp URL option would be nice. :-)
Comment 3 David A. Bandel 2008-10-01 21:32:21 EDT
Oops.  F4 says -- out of memory -- killed hald-runner.
Guess I can't install on a 256Mb system.
Comment 4 David Cantrell 2008-10-01 21:37:31 EDT
(In reply to comment #3)
> Oops.  F4 says -- out of memory -- killed hald-runner.
> Guess I can't install on a 256Mb system.

It's difficult and I have failed many times to get installations going on 256MB systems.  The absolute minimum required to run the installer in GUI mode is 192MB, but that's really pushing it.  F10 certainly has more going on than F9 since we are running hald, udev, and NetworkManager now.  I'm not sure if 192 is valid anymore.
Comment 5 David Cantrell 2008-10-01 21:44:55 EDT
(In reply to comment #2)
> Well, I still can't get an install out of F10 Beta netinst.iso.
> 
> This time, I'm not getting to the partitioner, anaconda is dying during module
> load.  The four FATALs on F3 are (not in order): jbd, aes, crypto_blkcipher,
> and dm_mod not found (and the install stops).

I'm going to say this falls in to our cryptodev support in the installer.

> Couple of notes:
> 1.  had to add askmethod to the pxelinux.cfg/default file or anaconda just kept
> looking for a non-existent CD-ROM.

Not sure what's happening there.

> 2.  the network config asks if I want ipv4 and ipv6.  I answer yes to both.  I
> provide the hostname for the URL.  Can't find the file install.img.  I remove
> the hostname, put in ipv4 decimal dotted notation address and it loads the file
> just fine.  If anaconda wget can't handle IPv6 addresses, why is it requesting
> AAAA RR from my DNS server (tole.pananix.com has both AAAA and A RRs). 
> Anaconda should only request A RRs if it chokes when provided AAAA RRs.

Anaconda as of Fedora 10 is now using NetworkManager for network interface configuration.  NetworkManager lacks IPv6 support and I have been working to extend NetworkManager to support IPv6.

I'd like to point out that IPv6 support was first added to anaconda under Fedora Core 5 and it's only now, Fedora 10, that IPv6 support is known to be broken because NetworkManager lacks it.  It was there in FC5, FC6, F7, F8, and F9.

I'm not changing the UI elements now because I'll only have to bring them back in under F11.  And in the amount of time I've been working on IPv6 support in anaconda, hardly anyone reports bugs about it.

> 3.  This test box has 256M RAM.  I had to play with the FB and shared mem
> memory options in BIOS to get this to run in text mode (where did this option
> go?).  First time, it crashed because I only had about 192Mb of memory
> available and it ran out of memory and killed the network manager (not a good
> idea on a network install) and that stopped the install.  Next time I had too
> much RAM and it tried to start a GUI and the GUI startup failed and I had
> _nothing_ on the screen.  Need to put the text option back.  This box will
> never have a monitor, keyboard, or GUI once installed.  Will do nothing but
> sniff packets.

I think at 192, you were hitting the limits we have.  To boot in text mode, you have to pass 'text' as a boot argument.  I do not know if the boot menu on the CD has that as a listed option anymore.

> A tftp URL option would be nice. :-)

Ooof.


...

There are a lot of reported problems in this bug, which is fine, we like solving problems.  However, it's difficult when multiple problems are listed in one bug.  We tend to like one problem per bug report, so let's go back to the first problem you noted with the crytodev issues.  Let's say this bug is cryptodev issues.  On that note, reassigning to dlehman, the anaconda team expert on cryptodev.  :)
Comment 6 David A. Bandel 2008-10-01 22:46:49 EDT
Making progress.

F10 install forcing text mode (as noted above -- although this boot option is not listed in any of the .msg files in the isolinux directory) works to a point.

1.  Every single byte of RAM in a 256 Mb system must be available even for a text install or it will fail (had to reallocate _all_ RAM possible to system, FB had 4Mb and 16Mb shared memory).

2.  Probably related to the missing modules noted above:
    partitioner cannot see any disk that has partitions (even if they are only Linux partitions).  Had to blank the disk by running fdisk from the shell and reboot to restart the install.
    partitioner blows up if default is used -- see missing modules above -- and only works creating plain jane Linux and swap partitions, creating LVM partitions is not possible.

3.  Following GRUB install, I'm back to the original reason for filing this bug report on FC9:  cannot find metadata (repomd.xml) file missing.  F3 shows the installer looking for repodata/repomd.xml on the web server where it got the install.img file from.  The netinst.iso contains no repodata directory or repomd.xml file.  This file is also not to be found on the system to be installed.

David A. Bandel
Comment 7 Andy Lindeberg 2008-10-02 10:10:52 EDT
Just to clarify, we did deliberately remove the text mode option from the options on the splash screen. As we add more features to graphical mode, text mode becomes harder and harder to keep up to date due to limited screen space, so the removal of text as an option was one of the steps we have taken to encourage people who don't want to or can't do a graphical install to use VNC, not text mode.

Text mode has never had the option to create LVMs, only to view them - partitioning is one of the areas where text mode has increasingly fallen behind. So you are correct in saying that creating LVMs is not possible, but that is expected behavior, not a bug.

Have you tried a VNC install, and if so, how did it go?
Comment 8 David A. Bandel 2008-10-02 12:03:33 EDT
Not yet.  Considering that with this system that only has 256Mb of RAM it took modifying the BIOS to make every byte available so as not to hit the OOM killer (which has been stopping installs) I didn't want to run yet another process.  However, I will give it a go and report back later.
Comment 9 David Lehman 2008-10-02 17:20:13 EDT
> Well, I still can't get an install out of F10 Beta netinst.iso.
> 
> This time, I'm not getting to the partitioner, anaconda is dying during module
> load.  The four FATALs on F3 are (not in order): jbd, aes, crypto_blkcipher,
> and dm_mod not found (and the install stops).

The text mode installer does not support creation of LVM devices or encrypted block devices. The module loading errors are unrelated.

Module load errors also will not stop the install. I have just finished an
install of F10-Beta with encrypted automatic partitioning.

What do you mean by "the install stops"? Are you getting OOM kills or something
else?

If the problem here is that you cannot create LVM devices or encrypted devices because you are using the text mode installer we should close this bug. New bugs can be opened for other problems.


Even though we are supposed to limit this bug to the cryptodev problems, I will add something else:

> 3.  Following GRUB install, I'm back to the original reason for filing this bug
> report on FC9:  cannot find metadata (repomd.xml) file missing.  F3 shows the
> installer looking for repodata/repomd.xml on the web server where it got the
> install.img file from.  The netinst.iso contains no repodata directory or
> repomd.xml file.  This file is also not to be found on the system to be
> installed.

The repo metadata should be found with the repo (wherever the packages are), not on the boot media. Does this help at all? If not, a new bug would be a good idea.
Comment 10 David A. Bandel 2008-10-03 07:37:40 EDT
VNC install fails -- invokes the OOM killer again.  Guess Fedora can't be netinstalled onto a system with 256Mb RAM.  Only text install works (barely) and since it can't partition the disk and is being ripped out anyway, none of my 128Mb or 256Mb systems can get a fresh Fedora install or update.

You can close this bug, I need something I can netinstall on a Yaris (128-256Mb RAM) as I don't have a fleet of SUVs (1Gb+ RAM).  Nor do I see a need to add RAM to systems that will only ever be remote X terminals and/or routers and the like.

Let me tell you what I was trying to do:
I have 16 systems for student use in a grade school.  They have 256Mb RAM.  They boot, run 'X -query <monsterserver>'.  I wanted to fresh install Fedora via netboot.  Obviously won't happen.  These systems need only 128Mb (perhaps only 64Mb) RAM to run X as that is _all_ they run.  In fact, I think one (old) system does only have 128Mb RAM.  I wanted netboot because these systems don't have CD-ROMs and with netboot I can install all at once (I boot them PXE/TFTP for the install).

Thanx.

Note You need to log in before you can comment on or make changes to this bug.