Bug 465139 - sysklogd: useless (empty) debuginfo package
sysklogd: useless (empty) debuginfo package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 15:23 EDT by Ville Skyttä
Modified: 2008-10-25 21:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 21:19:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Let rpmbuild strip binaries (876 bytes, patch)
2008-10-01 15:23 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-10-01 15:23:06 EDT
Created attachment 319155 [details]
Let rpmbuild strip binaries

sysklogd 1.5-2 produces a useless (empty) debuginfo package.  Fix attached.

On the other hand I'm not sure how useful the debuginfo is even after this, considering -fomit-frame-pointer is added to the compilation flags in Makefile.  Is it (and -O3) desirable for this package?
Comment 1 Jeroen van Meeuwen 2008-10-16 19:36:40 EDT
I'm not sure I understand what you mean wrt. the -fomit-frame-pointer / -O3 comment, but I've applied the patch and a 101K debuginfo is the result (instead of a 13K).

Created a build I would love you to take a look at. Should land in rawhide soon, of course;

http://koji.fedoraproject.org/koji/taskinfo?taskID=885480

Thank you, in advance
Comment 2 Ville Skyttä 2008-10-17 14:25:20 EDT
(In reply to comment #1)
> I'm not sure I understand what you mean wrt. the -fomit-frame-pointer / -O3
> comment,

man gcc:

-fomit-frame-pointer
   [...] It also makes debugging impossible on some machines.

OTOH, the man page also states that -fomit-frame-pointer is enabled at levels -O, -O2, -O3, -Os so I suppose it doesn't hurt in Fedora target machines - otherwise all our debuginfos should be essentially useless if the man page is correct.

Regarding the -O3, what are the reasons for using it instead of the standard Fedora $RPM_OPT_FLAGS (-O3 overrides -O2 as it appears later in the command line, see the build log)?  See the compiler flags section of the packaging guidelines: https://fedoraproject.org/wiki/Packaging/Guidelines#Compiler_flags

> but I've applied the patch and a 101K debuginfo is the result (instead
> of a 13K). Created a build I would love you to take a look at.

Looks good on a quick peek.
Comment 3 Jeroen van Meeuwen 2008-10-17 21:18:22 EDT
The -O3 is supplied by the upstream Makefile, I'm not changing that in my spec file right now as it is... The specfile just uses make %{?_smp_mflags} I'm guessing it has to do with the sysklogd being a core process with potentially a lot of throughput, and the lower the memory footprint, the better.
Comment 4 Jeroen van Meeuwen 2008-10-25 21:19:19 EDT
Please reopen if there's still a problem

Note You need to log in before you can comment on or make changes to this bug.