Bug 465162 - gnome-applet-sensors crashes at startup, Lenovo Thinkpad X200
gnome-applet-sensors crashes at startup, Lenovo Thinkpad X200
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-applet-sensors (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 17:13 EDT by Bryan O'Sullivan
Modified: 2008-11-22 11:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 11:54:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of gnome-applet-sensors just before a crash (50.47 KB, image/jpeg)
2008-10-01 17:13 EDT, Bryan O'Sullivan
no flags Details
ls -l /sys/class/hwmon/hwmon*/device/ > log (1.50 KB, text/plain)
2008-10-27 12:33 EDT, Bryan O'Sullivan
no flags Details
sensors >& sensors.out (1.51 KB, text/plain)
2008-11-01 16:48 EDT, Bryan O'Sullivan
no flags Details
strace -o strace.out /usr/libexec/sensors-applet (100.28 KB, text/plain)
2008-11-01 16:51 EDT, Bryan O'Sullivan
no flags Details

  None (edit)
Description Bryan O'Sullivan 2008-10-01 17:13:37 EDT
Created attachment 319166 [details]
Screenshot of gnome-applet-sensors just before a crash

Description of problem:

If I add gnome-applet-sensors by double clicking on it via "Add to Panel...", it starts, but fills the top status bar with dozens of sensor icons and then crashes after about 1 second.

Version-Release number of selected component (if applicable):

gnome-applet-sensors-1.8.2-2.fc9.x86_64
lm_sensors-3.0.2-1.fc10.x86_64
kernel-2.6.27-0.329.rc6.git2.fc10.x86_64

I've no idea how to get logging or debug info out of GNOME. If you need more information, please let me know how to provide it.
Comment 1 Christopher D. Stover 2008-10-22 12:05:02 EDT
Are you able to run gnome-applet-sensors from the command line and reproduce this bug to see if you get an error output in the terminal window?  Also, did you find an errors in the system logs?

I've also assigned this bug to Hans de Goede because he has taken over gnome-applet-sensors according to bug 190509.
Comment 2 Bryan O'Sullivan 2008-10-22 18:51:38 EDT
If I run /usr/libexec/sensors-applet from the command line, it simply hangs.  I don't know what else to do.
Comment 3 Hans de Goede 2008-10-23 04:31:14 EDT
(In reply to comment #0)
> Created an attachment (id=319166) [details]
> Screenshot of gnome-applet-sensors just before a crash
> 
> Description of problem:
> 
> If I add gnome-applet-sensors by double clicking on it via "Add to Panel...",
> it starts, but fills the top status bar with dozens of sensor icons and then
> crashes after about 1 second.
> 
> Version-Release number of selected component (if applicable):
> 
> gnome-applet-sensors-1.8.2-2.fc9.x86_64
> lm_sensors-3.0.2-1.fc10.x86_64
> kernel-2.6.27-0.329.rc6.git2.fc10.x86_64
> 
> I've no idea how to get logging or debug info out of GNOME. If you need more
> information, please let me know how to provide it.

Hmm,

When the applet crashes do you get any dialog box, such as the first one (reload or not) shown here: ? 
http://www.davyd.id.au/articles/debugging-gnome-applets.shtml

Also can you do:
ls -l /sys/class/hwmon/hwmon*/device/ > log

And attach the generated log file here?
Comment 4 Bryan O'Sullivan 2008-10-27 12:32:40 EDT
I get the reload dialog box, but the applet crashes immediately again upon reload.
Comment 5 Bryan O'Sullivan 2008-10-27 12:33:35 EDT
Created attachment 321628 [details]
ls -l /sys/class/hwmon/hwmon*/device/ > log
Comment 6 Hans de Goede 2008-10-27 15:20:47 EDT
Some more questions I'm afraid:

1) what version of lm_sensors are you using, what does "rpm -q lm_sensors" say?
2) Can you please try "yum update lm_sensors"
3) Can you please run the "sensors" command and copy and paste the output here
4) Can you try one more time to run the applet from the cmdline, using the
   technique described here:
http://www.davyd.id.au/articles/debugging-gnome-applets.shtml
Comment 7 Bryan O'Sullivan 2008-11-01 16:47:36 EDT
1. lm_sensors-3.0.2-1.fc10.x86_64
2. The crash happens even if lm_sensors isn't configured.
3. See attachment.
Comment 8 Bryan O'Sullivan 2008-11-01 16:48:11 EDT
Created attachment 322182 [details]
sensors >& sensors.out
Comment 9 Bryan O'Sullivan 2008-11-01 16:51:04 EDT
Created attachment 322184 [details]
strace -o strace.out /usr/libexec/sensors-applet

I still can't run the sensors-applet from the command line because it blocks forever, and there's nothing relevant that I can see in Davyd's article that suggests how I can make progress past this.  See the attached strace output.
Comment 10 Hans de Goede 2008-11-02 04:01:39 EST
Ok I think sensors-applet does not like it (iow is buggy) when it cannot read certain values, iow when it gets an error like the errors shown by "sensors" in the attached output of that.

Can you try putting the following in /etc/sensors3.conf (add it at the end):
chip "thinkpad-*"
  ignore temp3
  ignore temp6
  ignore temp8
  ignore temp11
  ignore temp12
  ignore temp13
  ignore temp14
  ignore temp15
  ignore temp16

That should hide those non working temps (which are normal with the thinkpad acpi driver) from gnome-sensors-applet.

That should work around this problem, and pinpoint the cause, so that after this we can go looking into a real fix.
Comment 11 Bryan O'Sullivan 2008-11-02 12:07:06 EST
That does indeed work, thanks.

What's interesting is that I have another Thinkpad, an X60 running F-9, where this problem doesn't occur.  It's either new to the X200 hardware, or new to F-10.
Comment 12 Hans de Goede 2008-11-03 06:13:05 EST
Ok,

I've managed to reproduce this by patching a hwmon driver on my system to return errors when read like the hwmon thinkpad acpi code does (which is sort of special).

Here is a package (once finished building) which should fix this:
http://koji.fedoraproject.org/koji/taskinfo?taskID=915419

Can you remove the relevant lines from sensors3.conf, so that the crash returns and then try this version please?
Comment 13 Hans de Goede 2008-11-03 06:16:06 EST
About your 2 thinkpads, this problem is thinkpad specific, but should show up on any thinkpad. The thinkpad hwmon code triggering this is new in the latest kernel which currently only is available in rawhide.
Comment 14 Bryan O'Sullivan 2008-11-03 09:12:36 EST
Hans, your patched version of the package works perfectly (and yes, I tidied up /etc/sensors3.conf beforehand).  Thanks!
Comment 15 Fedora Update System 2008-11-06 04:56:57 EST
gnome-applet-sensors-2.2.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-applet-sensors-2.2.1-1.fc10
Comment 16 Fedora Update System 2008-11-22 11:54:44 EST
gnome-applet-sensors-2.2.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.