Bug 465168 - Another spot where mirror subdevices are counted as logical volumes
Another spot where mirror subdevices are counted as logical volumes
Status: CLOSED DUPLICATE of bug 431760
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 17:34 EDT by Corey Marthaler
Modified: 2010-01-11 22:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 04:17:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-10-01 17:34:52 EDT
Description of problem:
There are only 2 LVs (both mirrors) in this volume group, yet lvm warns of eight.

[root@taft-02 ~]# lvs
  LV                         VG             Attr   LSize   Origin Snap%  Move Log                             Copy%  Convert
  LogVol00                   VolGroup00     -wi-ao  66.19G                                                                  
  LogVol01                   VolGroup00     -wi-ao   1.94G                                                                  
  nonsyncd_secondary_2legs_1 helter_skelter mwi--- 600.00M                    nonsyncd_secondary_2legs_1_mlog               
  nonsyncd_secondary_2legs_2 helter_skelter mwi--- 600.00M                    nonsyncd_secondary_2legs_2_mlog               


[root@taft-02 ~]# lvs -a -o +devices
  LV                                    VG             Attr   LSize   Origin Snap%  Move Log                             Copy%  Convert Devices                                                                      
  LogVol00                              VolGroup00     -wi-ao  66.19G                                                                   /dev/sda2(0)                                                                 
  LogVol01                              VolGroup00     -wi-ao   1.94G                                                                   /dev/sda2(2118)                                                              
  nonsyncd_secondary_2legs_1            helter_skelter mwi--- 600.00M                    nonsyncd_secondary_2legs_1_mlog                nonsyncd_secondary_2legs_1_mimage_0(0),nonsyncd_secondary_2legs_1_mimage_1(0)
  [nonsyncd_secondary_2legs_1_mimage_0] helter_skelter Iwi--- 600.00M                                                                   /dev/sdg1(0)                                                                 
  [nonsyncd_secondary_2legs_1_mimage_1] helter_skelter Iwi--- 600.00M                                                                   /dev/sde1(0)                                                                 
  [nonsyncd_secondary_2legs_1_mlog]     helter_skelter lwi---   4.00M                                                                   /dev/sdf1(0)                                                                 
  nonsyncd_secondary_2legs_2            helter_skelter mwi--- 600.00M                    nonsyncd_secondary_2legs_2_mlog                nonsyncd_secondary_2legs_2_mimage_0(0),nonsyncd_secondary_2legs_2_mimage_1(0)
  [nonsyncd_secondary_2legs_2_mimage_0] helter_skelter Iwi--- 600.00M                                                                   /dev/sdg1(150)                                                               
  [nonsyncd_secondary_2legs_2_mimage_1] helter_skelter Iwi--- 600.00M                                                                   /dev/sde1(150)                                                               
  [nonsyncd_secondary_2legs_2_mlog]     helter_skelter lwi---   4.00M                                                                   /dev/sdf1(1)  


[root@taft-02 ~]# vgremove helter_skelter
Do you really want to remove volume group "helter_skelter" containing 8 logical volumes? [y/n]:

Version-Release number of selected component (if applicable):
2.6.18-116.el5

lvm2-2.02.40-3.el5    BUILT: Thu Sep 25 14:59:07 CDT 2008
lvm2-cluster-2.02.40-3.el5    BUILT: Thu Sep 25 15:00:54 CDT 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
cmirror-1.1.28-1.el5    BUILT: Tue Sep 30 15:48:54 CDT 2008
kmod-cmirror-0.1.18-1.el5    BUILT: Mon Sep 29 16:20:21 CDT 2008
Comment 1 Peter Rajnoha 2008-12-04 04:17:43 EST

*** This bug has been marked as a duplicate of bug 431760 ***

Note You need to log in before you can comment on or make changes to this bug.