Bug 465259 - lshal fails after several days, system_bus_socket: Connection refused
lshal fails after several days, system_bus_socket: Connection refused
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 09:43 EDT by Petr Sklenar
Modified: 2018-01-22 08:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
brctl (738 bytes, text/plain)
2008-10-17 11:59 EDT, Petr Sklenar
no flags Details
/etc/xen/NAME (596 bytes, application/octet-stream)
2008-10-17 12:00 EDT, Petr Sklenar
no flags Details
ifconfig -a (6.37 KB, text/plain)
2008-10-17 12:00 EDT, Petr Sklenar
no flags Details
virsh dumpxml NAME (1.33 KB, text/plain)
2008-10-17 12:01 EDT, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2008-10-02 09:43:30 EDT
Description of problem:
after some time I can not add network card type bridge xenbr0

Version-Release number of selected component (if applicable):

virt-manager-0.5.3-8.el5

How reproducible:


Steps to Reproduce:
1. start host machine
2. create xen in virt-manager, click for bridge network
3. after installation. in virt-manager click detail for that running xen and add new hw to that xen
4. you can add network cards type bridge br0 as many as you can
5. don't reboot host machine and let xen be running for some time like 2 days
6. click details for that running xen
7. possibility to add bridge network card is gray, you can add only virtual network
  
Actual results:
I cannot add new bridge network card after +-two or more days

Expected results:
I can add new bridge network card forever

Additional info:
when you restart host machine, you can add new network card type bridge as many as you can again ...
Comment 1 Daniel Berrange 2008-10-07 06:18:52 EDT
Please provide  the following as individual attachments to this bug

 - /root/.virt-manager/virt-manager.log
 - /var/log/xen/xend.log
 - Output of 'lshal'
 - Output of 'ifconfig -a'
 - Output of 'brctl'
 - Output of 'virsh dumpxml NAME' for the guest you are attempting to change
 - The file /etc/xen/NAME  for the guest you are attempting to change
Comment 2 Petr Sklenar 2008-10-17 11:59:29 EDT
Created attachment 320686 [details]
brctl
Comment 3 Petr Sklenar 2008-10-17 12:00:33 EDT
Created attachment 320687 [details]
/etc/xen/NAME
Comment 4 Petr Sklenar 2008-10-17 12:00:53 EDT
Created attachment 320688 [details]
ifconfig -a
Comment 5 Petr Sklenar 2008-10-17 12:01:23 EDT
Created attachment 320689 [details]
virsh dumpxml NAME
Comment 7 Cole Robinson 2009-01-21 16:55:06 EST
The problem is most likely the hal issue: we use hal in virt-manager to list usable bridge devices. If after some long period of time hal/dbus flakes out, virt-manager has no way to get the device listing.

Can you still reproduce this on rhel5.3?
Comment 8 Petr Sklenar 2009-01-22 18:46:31 EST
yes, 
it happens me with rhel5.3 too, machine was about 2 or 3 weeks running then lshal has same error like in Comment #6.
Comment 9 Daniel Berrange 2009-01-23 05:15:31 EST
This really isn't a virt-manager bug, DBus+HAL are compulsory and if either is disabled, then things are guarenteed to not work. If DBus or HAL are crashing please open a bug against DBus / HAL.
Comment 10 Cole Robinson 2009-01-23 15:38:56 EST
Okay, reassigning to dbus.
Comment 11 RHEL Product and Program Management 2009-03-26 12:59:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 RHEL Product and Program Management 2014-03-07 08:32:33 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 14 RHEL Product and Program Management 2014-06-02 09:01:17 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.