Bug 465277 - spec file bug
spec file bug
Status: CLOSED DUPLICATE of bug 482765
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 10:51 EDT by Levente Farkas
Modified: 2009-02-18 16:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 16:20:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-10-02 10:51:57 EDT
please modify the spec file the same way as the kvm spec file do it. this is the relevant part from kvm spec file:
-------------------------------------------------------
# systems like rhel build system does not have a recent enough linker so 
# --build-id works. this option is used fedora 8 onwards for giving info
# to the debug packages.

build_id_available() {
        echo "int main () { return 0; }" | gcc -x c -Wl,--build-id - 2>/dev/null
}

if build_id_available; then
        qemuldflags="-Wl,--build-id";
else
        qemuldflags="";
fi

# we need to install the data bits in a different path
sed -i 's/datasuffix=\"\/share\/qemu\"/datasuffix=\"\/share\/kvm\"/' qemu/configure
./configure --with-patched-kernel --kerneldir=$(pwd)/kernel --prefix=%{_prefix} --qemu-ldflags=$qemuldflags \
--audio-drv-list=oss,alsa
-------------------------------------------------------
thanks.
Comment 1 Bug Zapper 2008-11-25 22:28:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Levente Farkas 2009-02-18 16:20:22 EST

*** This bug has been marked as a duplicate of bug 482765 ***

Note You need to log in before you can comment on or make changes to this bug.