Bug 465282 - No sound after upgrade to Fedora 10 beta from Fedora 9
No sound after upgrade to Fedora 10 beta from Fedora 9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 11:36 EDT by Qiao
Modified: 2009-03-17 07:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 07:21:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info output before problem resolved (23.02 KB, text/plain)
2008-10-15 07:33 EDT, Qiao
no flags Details
alsa-info output after problem resolved (23.03 KB, text/plain)
2008-10-15 07:35 EDT, Qiao
no flags Details

  None (edit)
Description Qiao 2008-10-02 11:36:31 EDT
After upgrade to Fedora 10 beta from Fedora 9, sound card not work anymore, open Sound Refrences, I can see my sound card, driver is installed, when I test, just no sound. When I using Fedora 9, sound card work fine, I try to boot from Fedora 10 beta LiveCD, and no sound too.

Sound card infomation:
lspci -vvv

00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
        Subsystem: nVidia Corporation MCP67 High Definition Audio
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0 (500ns min, 1250ns max)
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at fe024000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
                Masking: 00000000  Pending: 00000000
        Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel



part of dmesg:

HDA Intel 0000:00:07.0: PCI INT A -> Link[AAZA] -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:07.0: setting latency timer to 64
ALSA sound/pci/hda/hda_intel.c:2083: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:758: codec_mask = 0x1
hda_codec: Unknown model for ALC660VD/ALC861VD, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=4 (0x14/0x16/0x15/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x1c, aux=0x0
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Headphone Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Mono Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Line-Out Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Mono Playback Switch, skipped
Comment 1 Qiao 2008-10-10 04:01:47 EDT
I install Fedora refresh from rawhide repository, my soundcard work fine now, but if upgrade Fedora 10 beta to Fedora rawhide, still no sound, I check sound driver, found no error, Is there any old configuraton file exists on the system? and it effect to the new driver?
Comment 2 Gideon Mayhak 2008-10-11 15:03:04 EDT
I am experiencing the same issue.  I have installed from F10 Beta and have no sound.  I have not tried reinstalling from rawhide, but I would prefer not to reinstall until the next "official" test release.  Is there a config file that I can change (like Qiao asks above), or would it be possible to have the next update to whatever component might be causing this include a forced change to the necessary files?  Let me know, and I will gladly attach and files needed to compare to Qiao's system to see what changed.

Here is my lspci output:

[gideon@gidux-laptop-rawhide ~]$ lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation MCP51 PCI-X GeForce Go 6100 (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)
Comment 3 Gideon Mayhak 2008-10-11 15:03:40 EDT
And I do have all the latest updates installed from rawhide.
Comment 4 Jaroslav Kysela 2008-10-14 08:03:42 EDT
You may try to remove /etc/asound.state and /etc/alsa/asound.state (if it exists). Also, disable (comment out via #) calling of alsactl or salsa in /etc/init.d/halt script temporary (otherwise bad configuration will be save again on shutdown from driver to asound.state file).

To compare "working" and "not working" configuration, please use alsa-info.sh script with --no-upload option. Attach results to this bug. Thanks.
Comment 5 Gideon Mayhak 2008-10-14 20:09:10 EDT
Deleting /etc/asound.state and commenting out the section in the halt script did it.  Thanks!  I have restored the section in the halt script and rebooted and it still works.  Thanks again.  I figure there's no need to post the output of alsa-info.sh, since whatever the issue was has been fixed.  You can count this closed, as far as I'm concerned.
Comment 6 Qiao 2008-10-15 07:33:18 EDT
Created attachment 320414 [details]
alsa-info output before problem resolved
Comment 7 Qiao 2008-10-15 07:35:22 EDT
Created attachment 320415 [details]
alsa-info output after problem resolved
Comment 8 Qiao 2008-10-15 07:36:42 EDT
I have resolved this problem use your method, thanks!
Comment 9 Christopher D. Stover 2008-10-22 21:42:31 EDT
Jaroslav: Should this ticket be closed since they were able to resolve their problem or leave it open to track a bug fix?
Comment 10 Qiao 2008-10-23 00:52:27 EDT
If anybody upgrade to Fedora 10 from Fedora 9, is there have same problom?
Comment 11 Jaroslav Kysela 2008-10-23 04:56:53 EDT
I would like to create a bug fix - file removal is just a workaround. I hope that attached files help me to determine the problem. Please, leave this bug open.
Comment 12 Joachim Backes 2008-11-11 03:42:52 EST
I made a fresh install of F10-preview including a yum update (kernel 2.6.27.4-79.fc10.i686), but no sound available. lspci shows the soundcard. No problems in F9.


00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
	Subsystem: Micro-Star International Co., Ltd. Device 5700
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0 (500ns min, 1250ns max)
	Interrupt: pin A routed to IRQ 21
	Region 0: I/O ports at e800 [size=256]
	Region 1: I/O ports at ec00 [size=128]
	Region 2: Memory at ee002000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [44] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0
Comment 13 Joachim Backes 2008-11-11 09:44:36 EST
Could solve my problem (Comment #12): By activating the volume control in the gnome panel, I could control the loudness in the playback area. Now I can hear sound.
Comment 14 Bug Zapper 2008-11-25 22:28:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Jaroslav Kysela 2009-03-17 07:21:28 EDT
Reported problems are fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.