Bug 465285 - ksdevice=bootif with a manual static IP configuration and ipv6 auto discovery fails
ksdevice=bootif with a manual static IP configuration and ipv6 auto discovery...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 11:52 EDT by James Laska
Modified: 2013-09-02 02:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 22:41:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-10-02 11:52:50 EDT
Description of problem:
PXE Boot with ksdevice=bootif, and attempting to manually initiate a static IP configuration in stage#1 fails

Version-Release number of selected component (if applicable):
 * rawhide=20081002/x86_64
 * anaconda-11.4.1.42-1

How reproducible:
100%

Steps to Reproduce:
1. PXE boot the noted rawhide tree
2. Add boot arguments: ksdevice=bootif
3. When prompted, enter lang=en and keymap=us
4. Select URL install method
                       +----+ Installation Method +----+                        
                       |                               |                        
                       | What type of media contains   |                        
                       | the installation image?       |                        
                       |                               |                        
                       |         Local CD/DVD          |                        
                       |         Hard drive            |                        
                       |         NFS directory         |                        
                       |         URL                   |                        
                       |                               |                        
                       |    +----+        +------+     |                        
                       |    | OK |        | Back |     |                        
                       |    +----+        +------+     |                        
                       |                               |                        
                       |                               |                        
                       +-------------------------------+                        
5. Enter a valid static IP configuration
                +-------------+ Configure TCP/IP +-------------+                
                |                                              |                
                | [*] Enable IPv4 support                      |                
                |        ( ) Dynamic IP configuration (DHCP)   |                
                |        (*) Manual configuration              |                
                |                                              |                
                | [*] Enable IPv6 support                      |                
                |        (*) Automatic neighbor discovery      |                
                |        ( ) Dynamic IP configuration (DHCPv6) |                
                |        ( ) Manual configuration              |                
                |                                              |                
                |        +----+               +------+         |                
                |        | OK |               | Back |         |                
                |        +----+               +------+         |                
                |                                              |                
                |                                              |                
                +----------------------------------------------+                
    
6. Select OK to proceed
  
Actual results:

tty1 shows ...

           +-------------------------------------------------------+            
           |                                                       |            
           | Waiting for NetworkManager to configure eth1...       |            
           |                                                       |            
           +-------------------------------------------------------+            

Then returned to TCP/IP Config screen ...

                +-------------+ Configure TCP/IP +-------------+                
                |                                              |                
                | [*] Enable IPv4 support                      |                
                |        ( ) Dynamic IP configuration (DHCP)   |                
                |        (*) Manual configuration              |                
                |                                              |                
                | [*] Enable IPv6 support                      |                
                |        (*) Automatic neighbor discovery      |                
                |        ( ) Dynamic IP configuration (DHCPv6) |                
                |        ( ) Manual configuration              |                
                |                                              |                
                |        +----+               +------+         |                
                |        | OK |               | Back |         |                
                |        +----+               +------+         |                
                |                                              |                
                |                                              |                
                +----------------------------------------------+                


tty4 shows 

nm-system-settings: ifconfig-fedora: error Invalid IP4 prefix '0'

(see screenshot at http://jlaska.fedorapeople.org/bootif-static-ip.png)

Expected results:
Manually enter static IP configuration

Additional info:

If I deselect ipv6 ... it all works:

                +-------------+ Configure TCP/IP +-------------+                
                |                                              |                
                | [*] Enable IPv4 support                      |                
                |        ( ) Dynamic IP configuration (DHCP)   |                
                |        (*) Manual configuration              |                
                |                                              |                
                | [ ] Enable IPv6 support                      |                
                |        (*) Automatic neighbor discovery      |                
                |        ( ) Dynamic IP configuration (DHCPv6) |                
                |        ( ) Manual configuration              |                
                |                                              |                
                |        +----+               +------+         |                
                |        | OK |               | Back |         |                
                |        +----+               +------+         |                
                |                                              |                
                |                                              |                
                +----------------------------------------------+                
         +--------------+ Manual TCP/IP Configuration +---------------+         
         |                                                            |         
         | Enter the IPv4 and/or the IPv6 address and prefix          |         
         | (address / prefix).  For IPv4, the dotted-quad netmask     |         
         | or the CIDR-style prefix are acceptable. The gateway and   |         
         | name server fields must be valid IPv4 or IPv6 addresses.   |         
         |                                                            |         
         | IPv4 address: 192.168.32.38___ / 255.255.252.0___          |         
         | Gateway:      192.168.35.254___________________________    |         
         | Name Server:  192.168.32.2_____________________________    |         
         |                                                            |         
         |            +----+                      +------+            |         
         |            | OK |                      | Back |            |         
         |            +----+                      +------+            |         
         |                                                            |         
         |                                                            |         
         +------------------------------------------------------------+  
        +------------------------+ URL Setup +-------------------------+        
        |                                                              |        
        |         Please enter the URL containing the Fedora           |        
        |         installation image on your server.                   |        
        |                                                              |        
        | ____________________________________________________________ |        
        |                                                              |        
        |            +----+                       +------+             |        
        |            | OK |                       | Back |             |        
        |            +----+                       +------+             |        
        |                                                              |        
        |                                                              |        
        +--------------------------------------------------------------+
Comment 1 David Cantrell 2008-10-06 22:41:42 EDT
This should be working with anaconda-11.4.1.44-1.

The IPv6 interface options and boot arguments have been disabled for F-10 since NetworkManager lacks IPv6 support.

ksdevice=DEVICE, ksdevice=BOOTIF (with BOOTIF=01-xx-xx-xx-xx-xx-xx supplied too), and ksdevice=link all work now.  You do not need to pass noipv6 anymore.

Additionally, the askmethod dialog box is not presented if you provide repo= and stage2= boot parameters.

Note You need to log in before you can comment on or make changes to this bug.