Bug 465290 - Some Chinese character cannot display when installing Fedora 10 beta
Some Chinese character cannot display when installing Fedora 10 beta
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 12:14 EDT by Qiao
Modified: 2008-10-06 10:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 10:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Fedora 10 beta installation (109.23 KB, image/png)
2008-10-02 12:14 EDT, Qiao
no flags Details
Chinese font display problem fix patch (1.00 KB, patch)
2008-10-04 13:40 EDT, Qiao
no flags Details | Diff

  None (edit)
Description Qiao 2008-10-02 12:14:45 EDT
Created attachment 319257 [details]
Screenshot of Fedora 10 beta installation

Some Chinese character just display as a unicode number, and I test Japanese and Korean, its display correctly.
Comment 1 Chris Lumens 2008-10-03 16:00:24 EDT
Looks like we're either missing characters out of the font, or anaconda isn't including the right font anymore.  Has there been a change in which Chinese fonts we need to use in Fedora?
Comment 2 Qiao 2008-10-04 13:40:42 EDT
Created attachment 319471 [details]
Chinese font display problem fix patch
Comment 3 Qiao 2008-10-04 13:46:13 EDT
Because new Chinese font package have changed font file name, so anaconda cannot add Chinese font into installation image.
Comment 4 Chris Lumens 2008-10-06 10:00:57 EDT
Thanks for the patch.  This will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.