Bug 465294 - ACPI: EC: GPE storm detected, disabling EC GPE
ACPI: EC: GPE storm detected, disabling EC GPE
Status: CLOSED DUPLICATE of bug 467820
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 12:28 EDT by Naresh
Modified: 2008-10-22 11:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 11:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naresh 2008-10-02 12:28:20 EDT
Description of problem:

kernel is emitting the GPE storm detected errors. Not sure if these are harmful messages.

Version-Release number of selected component (if applicable):

[nareshv ~]$ uname -r
2.6.27-0.377.rc8.git1.fc10.i686

How reproducible:

Always

Steps to Reproduce:
1. Boot MacBook Pro 4,1 (penryn) Into Fedora
2. After few mins the /var/log/messages fills with errors
3.
  
Actual results:

errors in syslog like below

------ 8< cut   >8 ----------
[nareshv ~]$ sudo grep 'GPE ' /var/log/messages 
Oct  2 09:55:19 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 10:50:16 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 11:01:19 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 11:13:29 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 11:27:03 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 19:03:43 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 19:03:46 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 19:40:06 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 19:43:03 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 19:45:07 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 20:46:28 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE
Oct  2 21:07:34 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 21:30:14 fallenAngel kernel: ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
Oct  2 21:39:18 fallenAngel kernel: ACPI: EC: GPE storm detected, disabling EC GPE



Expected results:


Additional info:
Comment 1 Gil Ristow Branco 2008-10-07 09:17:33 EDT
Well, well, well.

Now I know that I'm not alone in the GPE storm.

I have no idea what it is.

But I'm not so lucky to see those messages in the /var/log/messages file.

Here is my notebook config and, below, the few messages I get.
-----------
Notebook: Philips 13NB8504/78 
--------------------------------------------------------------------------------
Philips 13NB8504/78 - Only available in Brasil
http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?scy=BR&slg=BRP&cat=CA00304_CA&sct=SU00331_SU&session=20081006201907_201.17.109.195&grp=PC_PRODUCTS_GR&ctn=13NB8504/78&mid=Link_ProductInformation&hlt=Link_ProductInformation

It's an OEM version of the Twinhead J13S Series
http://www.twinhead.com.tw/product_notebook/J13S.asp

Model: Intel Core 2 Duo T7300@2.00GHz (4MB L2 Cache) / 2GB RAM
Videocard: Intel® GM965 built-in (Mobile Intel 965 Express chipset family)
Network: Integrated 10/100/1000 Mbps Ethernet VIA Velocity family Gigabit
Wifi: Intel® Pro/Wireless 3945ABG (802.11a/b/g)
Bluetooth: Yes (CSR Bluetooth Device)
Webcam: 1.3 Mega-pixel (USB2.0 UVC PC Camera)
Touchpad: Synaptics PS/2 port touchpad (It worked fine with Mandriva, and with the from-DVD FC9 installation. After some updates it still points but the pad has no 'two tap' funcition. Not a big problem at all.)
Hotkey (Home, Eject, Suspend ...): Media player quick key (only in Windows)
Display: WXGA TFT LCD screen (1280 x 800)
OS: 32bit Vista Home Preminum (original) / Fedora 9
Kernel: 2.6.25.14-108 - The newers hang on boot!!! -- See below!
Suspend on Disk: Only in Windows
Suspend on RAM: Only in Windows
Comments:
BIOS is AMI v2.061
It works fine with Windows Vista.
I've used Mandriva a few weeks and liked it. Mandriva Live was the only one booting then.
Later tried a Live version of Fedora 9 that was booting so installed FC9. 
It works very good if I do not mess with the latest core versions. I'm stuck with kernel 2.6.25.14-108 because it simply do not boot with any newer one.
The grub does its job, then comes that message

=-=-=-=-=-=-=-=-=
Booting 'Fedora (2.6.26.5-45.fc9.i686)'

Root (hd0.4)
Filesystem type is ext2fs, partiotion type 0x83
kernel /boot/vmlinuz-2.6.26.5-45-fc9.i686 ro root=UUID=c93e83zz-037d-4806-907d-8311b0437f98 rhgb quiet
[Linux-bzImage, setup=0x3000, size=0x203c60]
initrd /boot/initrd-2.6.26.5-45.fc9.i686.img
[Linux-initrd @ 0x37d58000, 0x29739a bytes]

Decompressing Linux... Paersing ELF... done
Boorting the kernel
ACPI: EC: GPE storm detected, disabling EC GPE
=-=-=-=-=-=-=-=-=

and nothing else happens.
I'm looking for a solution for it. In the meanwhile I'll be with my trustfull core 2.6.25.14-108.

If you know how to deal with such bad behaviour, please let me know.

I've been thinking about a small modification of the kernel boot line. 

Maybe a parameter near the "rhgb quiet" to disable the ACPI and get rid of theis storm.
Comment 2 Gil Ristow Branco 2008-10-07 20:35:28 EDT
Hi all,

I've been poking some parameters into the boot command line in grub.

I found one (acpi=off) that makes it boot, but it looses all acpi functions.

I consider it a kind of a dirty job.  It's nonsense to disable acpi in a notebook, which is my case.

In fact, in a very few times, the system boots without that parameter, but I could not identify why it works or not.

In a nutshell, I added the parameter to the grub boot line, and it looks like this:
...  ro acpi-off root=UUID=c93e83zz-037d-4806-907d-8311b0437f98 rhgb quiet

So I believe there is something mistaken in the module that interfaces with the acpi hardware.

I hope it is of any help for anyone who can deal with this issue.

Gil
Comment 3 Zuirdj 2008-10-15 20:37:26 EDT
Same bug on a MSI Wind.

It seems it was solved:

https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/270017

http://bugzilla.kernel.org/show_bug.cgi?id=10724#c142
Comment 4 Dave Jones 2008-10-22 11:21:47 EDT

*** This bug has been marked as a duplicate of bug 467820 ***

Note You need to log in before you can comment on or make changes to this bug.