Bug 465306 - setup missing GID for user dbus
setup missing GID for user dbus
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus (Show other bugs)
5.3
All Linux
medium Severity urgent
: rc
: ---
Assigned To: David Zeuthen
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 13:33 EDT by Doug Chapman
Modified: 2013-03-05 22:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 13:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-10-02 13:33:17 EDT
Description of problem:
in recent RHEL5 nightly installs the dbus service fails to start because it cannot find the GID for dbus:

Starting system message bus: Failed to start message bus: Could not get UID and GID for username "dbus"
[FAILED]

This is a regression.


Version-Release number of selected component (if applicable):
setup-2.5.58-4.el5



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-10-02 13:38:23 EDT
Actually it looks like this isn't in /etc/group from the inital one in the setup package.  I am not sure what was supposed to add it.... might be the dbus package itself.  Looks like I was too quick to assign this to setup.
Comment 2 Doug Chapman 2008-10-02 13:43:12 EDT
Yup, looks like this is dbus itself.  There was a change to the rpm script in this release that appears to not be working:

In the OLD script:
/usr/sbin/useradd -c 'System message bus' -u 81 \
	-s /sbin/nologin -r -d '/' dbus 2> /dev/null || :



in the NEW script it uses a variable for the UID but evidently that variable isn't set:


/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
	-s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
Comment 3 Doug Chapman 2008-10-02 13:47:32 EDT
OK, looks like you guys are fast and already fixed this.  Looks like it works OK in  dbus-1.1.2-11.el5

closing

- Doug

Note You need to log in before you can comment on or make changes to this bug.