Bug 465310 - gdb 6.8 can't print fortran logical (kind=8)
gdb 6.8 can't print fortran logical (kind=8)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdb (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Kratochvil
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 13:42 EDT by Alan Matsuoka
Modified: 2010-10-23 00:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: gdb-6.8-31.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix + testcase. (6.82 KB, patch)
2008-10-04 23:38 EDT, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Alan Matsuoka 2008-10-02 13:42:47 EDT
[ben@x61 tmp]$ gfortran43 -g missing-dwarf-parameters.f90
[ben@x61 tmp]$ gdb a.out
GNU gdb Fedora (6.8-23.el5)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(gdb) b 124
Breakpoint 1 at 0x80487cd: file missing-dwarf-parameters.f90, line 124.
(gdb) r
Starting program: /tmp/a.out

Breakpoint 1, moreparams () at missing-dwarf-parameters.f90:124
124            call breakhere2
Current language:  auto; currently fortran
(gdb) p l4
$1 = <error reading variable>

Due to 198965 this problem can only be reproduced when the test program is compiled with gcc 4.3.

I haven't tested this on a 64b platform but I expect that it will have work just fine on 64b platforms.
Comment 1 Jan Kratochvil 2008-10-04 23:38:42 EDT
Created attachment 319488 [details]
Fix + testcase.

logical*8 did not work even on 64bit.
Comment 6 Chris Ward 2009-07-03 14:10:18 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 9 errata-xmlrpc 2009-09-02 07:26:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1361.html

Note You need to log in before you can comment on or make changes to this bug.