Bug 465313 - F10Beta LiveCD install to eeePC 701 fail
F10Beta LiveCD install to eeePC 701 fail
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 14:07 EDT by Donald Harper
Modified: 2008-11-03 11:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 11:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda save file from attempt (30.44 KB, text/plain)
2008-10-02 14:07 EDT, Donald Harper
no flags Details
/home/fedora/.xsession-errors from install attempt (42.84 KB, text/plain)
2008-10-02 15:38 EDT, Donald Harper
no flags Details

  None (edit)
Description Donald Harper 2008-10-02 14:07:52 EDT
Created attachment 319271 [details]
anaconda save file from attempt

Description of problem:
Anaconda fails on disk partitioning when trying to install to harddrive while booted with F10 Beta LiveCD

Version-Release number of selected component (if applicable):
fedora-release-9.91-1
anaconda-11.4.1.40-1

How reproducible:
Every time tried

Steps to Reproduce:
1. LiveCD iso to USB (vfat formatted)
2. Boot eeePc 701 with 16G SDHC card in reader and USB stick in USB slot 1
3. Select Install to Hard Drive from desktop
4. Answer questions, under disk partitioning, select use all partitions and default layout.  Error happens regardless of encryption setting.
5. Agree to all dialogues.
6. Watch go boom.
  
Actual results:
Attached error

Expected results:
Install to hard drives

Additional info:
Comment 1 David Lehman 2008-10-02 14:57:04 EDT
What do you see on tty4 and tty5 when this happens?

And what do you see if you manually run 'lvm pvcreate -ff -y -vvv /dev/sdc1'?
Comment 2 Donald Harper 2008-10-02 15:37:02 EDT
tty4 -> getty running (LiveCD)
tty5 -> mkfs output 
        tune2fs on /dev/sda1
        e2label
        swapoff
        Running... ['udevsettle']
        Command failed: Can not access device
        COmmand failed: Device already exists
        Command failed: Can not access device
        swapoff
        udevsettle (No errors this time)

Will attach .xsession-errors which seems to have some output from anaconda.


Command requested:
[root@localhost ~]# lvm pvcreate -ff -y -vvv /dev/sdc1
        Processing: pvcreate -ff -y -vvv /dev/sdc1
        O_DIRECT will be used
      global/locking_type not found in config: defaulting to 1
      File-based locking selected.
      global/locking_dir not found in config: defaulting to /var/lock/lvm
      Locking /var/lock/lvm/P_orphans WB
        Opened /dev/sdc1 RW O_DIRECT
        /dev/sdc1: block size is 1024 bytes
      /dev/sdc1: No label detected
        Closed /dev/sdc1
        Opened /dev/sdc1 RW O_EXCL O_DIRECT
        Closed /dev/sdc1
      /dev/sdc1: size is 31374882 sectors
        Opened /dev/sdc1 RW O_DIRECT
        /dev/sdc1: block size is 1024 bytes
        Closed /dev/sdc1
      metadata/pvmetadatasize not found in config: defaulting to 255
      metadata/pvmetadatacopies not found in config: defaulting to 1
      /dev/sdc1: size is 31374882 sectors
        Opened /dev/sdc1 RW O_DIRECT
        Wiping /dev/sdc1 at 4096 length 1
        /dev/sdc1: block size is 1024 bytes
        Closed /dev/sdc1
    Set up physical volume for "/dev/sdc1" with 31374882 available sectors
      Scanning for labels to wipe from /dev/sdc1
        Opened /dev/sdc1 RW O_DIRECT
        /dev/sdc1: block size is 1024 bytes
        Closed /dev/sdc1
    Zeroing start of device /dev/sdc1
        Opened /dev/sdc1 RW O_DIRECT
        Wiping /dev/sdc1 at sector 0 length 4 sectors
        /dev/sdc1: block size is 1024 bytes
        Closed /dev/sdc1
      Writing physical volume data to disk "/dev/sdc1"
        lvmcache: /dev/sdc1: now in VG #orphans_lvm2 (#orphans_lvm2)
        Creating metadata area on /dev/sdc1 at sector 8 size 376 sectors
        Opened /dev/sdc1 RW O_DIRECT
        /dev/sdc1: block size is 1024 bytes
      /dev/sdc1: Writing label to sector 1
        Closed /dev/sdc1
  Physical volume "/dev/sdc1" successfully created
      Unlocking /var/lock/lvm/P_orphans
[root@localhost ~]#
Comment 3 Donald Harper 2008-10-02 15:38:00 EDT
Created attachment 319286 [details]
/home/fedora/.xsession-errors from install attempt
Comment 4 Donald Harper 2008-10-10 07:38:28 EDT
As a data point, I was able to use install via boot.iso/network install.
Comment 5 Jeremy Katz 2008-10-22 10:19:13 EDT
What physical device is sdc?  And were there any swap partitions on anything before you started?
Comment 6 Donald Harper 2008-10-22 13:37:53 EDT
sdc is a sd card in the card reader slot.

sda might have had swap, but I did select to remove all partitions from both drives...
Comment 7 Jeremy Katz 2008-10-22 13:55:33 EDT
We at least try to turn off swap, but if it's actively in use, then there's not much that can be done.

And unfortunately, the log has little of note that can really tell me what went wrong.  Can you reproduce with the live installer still?  If so, I can try to get some debugging bits for you to use that might give more of an idea of what's going wrong
Comment 8 Donald Harper 2008-10-22 14:36:30 EDT
I have not tried it with Spin2, but since it is a secondary box, I have no issues whacking it to give it a try...

don
Comment 9 Darren Fulton 2008-10-31 15:24:13 EDT
This may be related or may not.  There is a bug somewhere that breaks SDHC cards when used in first generation ASUS eeePCs.  My 16 GB SDHC _worked_fine_ under Fedora 8 but does not work under Fedora 9 or Fedora release 9.92 (Rawhide).

dmseg shows, when popping the card in and out:

sd 2:0:0:0: timing out command, waited 360s
sd 2:0:0:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 2:0:0:0: [sdb] Sense Key : Hardware Error [current]
sd 2:0:0:0: [sdb] Add. Sense: Unrecovered read error
end_request: I/O error, dev sdb, sector 31388656
Buffer I/O error on device sdb, logical block 3923582
sd 2:0:0:0: timing out command, waited 360s
sd 2:0:0:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 2:0:0:0: [sdb] Sense Key : Hardware Error [current]
sd 2:0:0:0: [sdb] Add. Sense: Unrecovered read error
end_request: I/O error, dev sdb, sector 31388656
Buffer I/O error on device sdb, logical block 3923582

I'll be glad to do some testing if you don't have access to one of these computers or cards.  Just let me know.  Thank you.
Comment 11 Donald Harper 2008-10-31 16:03:21 EDT
Using Snap3 XFCE LiveCD, I was able to install as long I as I ignored the SDHC card.
Comment 12 Darren Fulton 2008-10-31 18:26:59 EDT
By the way, I'm pretty sure that this is the on-board (but USB connected) card reader's info from /proc/bus/usb/devices:

T:  Bus=03 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1     
P:  Vendor=0951 ProdID=1606 Rev= 1.00                            
S:  Manufacturer=ENE                                             
S:  Product=UB6225                                               
S:  SerialNumber=146030377350                                    
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=498mA                           
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms                              
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
Comment 13 Jeremy Katz 2008-11-03 11:02:38 EST
Based on the further comments, it looks that this is mostly due to the kernel thing and not anything that we can really reasonably do anything about in anaconda

Note You need to log in before you can comment on or make changes to this bug.