Bug 465331 - X crash when enabling compiz on radeon
X crash when enabling compiz on radeon
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 15:50 EDT by Mads Kiilerich
Modified: 2008-10-06 05:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 05:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old - AIGLX: Suspending AIGLX clients for VT switch (55.54 KB, application/octet-stream)
2008-10-02 15:50 EDT, Mads Kiilerich
no flags Details
Xorg.0.log - but it is probably from the current session, after a reboot (69.25 KB, application/octet-stream)
2008-10-02 15:53 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2008-10-02 15:50:37 EDT
Created attachment 319287 [details]
Xorg.0.log.old - AIGLX: Suspending AIGLX clients for VT switch

Description of problem:

When I try to "enable desktop effects" the screen flickers, decorations disappears for a micro-second - and then my X session is terminated.

ATI RV516, and I am using nomodeset - otherwise nothing works.

I don't know whether it should be assigned to xorg or compiz - please reassign or request more info.

I will provide Xorg.0.log and Xorg.0.log.old


Version-Release number of selected component (if applicable):

xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc10.i386

compiz-fusion-0.7.6-6.fc10.i386
compiz-0.7.6-11.fc10.i386
compiz-fusion-gnome-0.7.6-6.fc10.i386
gnome-compiz-manager-0.10.4-4.fc10.i386
libcompizconfig-0.7.6-2.fc10.i386
compiz-manager-0.6.0-8.fc10.noarch
compiz-gnome-0.7.6-11.fc10.i386


How reproducible:

Sure, I can't avoid reproducing it... Running on new home folder created after f10 upgrade.
Comment 1 Mads Kiilerich 2008-10-02 15:53:15 EDT
Created attachment 319288 [details]
Xorg.0.log - but it is probably from the current session, after a reboot
Comment 2 Mads Kiilerich 2008-10-06 05:45:35 EDT
Closing.

The reported issue isn't an issue with recent rawhide packages.

But compiz isn't stable - see bug 465760

Note You need to log in before you can comment on or make changes to this bug.