Bug 465335 - ripping multi-disc albums is broken.
ripping multi-disc albums is broken.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 16:22 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 12:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-10-02 16:22:46 EDT
sound-juicer seems to have grown the ability to detect multi-disc CDs.
I'm not sure what heuristic it uses, but it seems that if the CDDB entry has something like 'disc 1' at the end of the title, sj now lops that off, and puts the disc number in a box labelled 'disc:' (this box serves no purpose afaict)

This 'feature' completely ruins the organisation of my music folder (stored in artist/album sub-directories).  Due to this change, all songs on multi disc CDs end up in the same folder.
So now I have a folder with.

01 - song 1 from disc1.ogg
01 - song 1 from disc2.ogg
02 - song 2 from disc1.ogg
..

Completely ruining the possibility of playing that album in its correct sequential order with the command line.
(Also, I wonder what happens when the same track number on two different discs has the same name?)

It also seems to confuse the hell out of rhythmbox, which sees it as one album, and doesn't order the songs in the order they are on the CD.
Comment 1 Edgar Hoch 2009-03-22 18:52:42 EDT
This is also true with sound-juicer-2.24.0-1.fc10.x86_64.
Comment 2 Bastien Nocera 2009-04-14 12:39:24 EDT
The disc number box contains the disc number, which is recognised by Rhythmbox, and plenty of other music players.

You can make sure the disc number appears in the directory name by using:
 * %dn -- disc and track number (i.e Disk 2 - 6, or 6)
 * %dN -- disc number, zero padded (i.e d02t06, or 06)

If rhythmbox can't recognise the tags, then either they're not in the file (which would be a bug in the gstreamer plugins), or there's a bug in Rhythmbox.

As for the "same track number, same track name", I don't have a good answer I'm afraid. Please file an upstream bug about this.
Comment 3 Edgar Hoch 2009-04-14 14:09:32 EDT
I want to add some information.

I saw that sound-juicer uses musicbrainz.org as the cddb database
while other ripping tools like grip users (per default) freedb.freedb.org as the cddb database.

The entries in freedb and musicbrainz are different for the same disc.
One cddb hat the cd number in the title, so ripping creates two different directories.
The other has not, so the same directory will be created and uses by both discs. It may have the volume number in an extra value.
Also some have different titles, some different authors, which creates different directories and names with different ripping tools (e.g. sound-juicer, grip).
I tested it with two discs of a musical ("Tanz der Vampire") and others.

Including the disc number and track number into the filename or directory name was the solution I searched for. But I doesn't found the documentation. Thanks for mention it here!

The values must be changed in the gconf database directly (using gconf-editor for example), because the preferences window of sound suicer does not offer that possibility (gconf path /apps/sound-juicer/).

I think that the upstream bug should include that using volume numbers as part of the directory name or file name should be an option in the preferenced dialog.
Also adding that option (%dn, %dN, and evtually others)) to the gconf description of /apps/sound-juicer/path_pattern and /apps/sound-juicer/file_pattern would be great.

Note You need to log in before you can comment on or make changes to this bug.