Bug 465336 - Black border around windows and menus after enabling desktop effects
Black border around windows and menus after enabling desktop effects
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 465588 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 16:23 EDT by Per Thomas Jahr
Modified: 2009-02-08 07:35 EST (History)
6 users (show)

See Also:
Fixed In Version: Fedora 11 alpha
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 07:35:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Black border after enabling desktop effects. (185.31 KB, image/png)
2008-10-02 16:23 EDT, Per Thomas Jahr
no flags Details
Xorg.0.log booting up on Thinkpad X61 (Intel 965 graphics) (40.13 KB, text/plain)
2008-10-04 12:34 EDT, Tom London
no flags Details
Xorg.0.log booting up on Thinkpad X60 (Intel 945 graphics) (no fat borders) (38.97 KB, text/plain)
2008-10-04 12:36 EDT, Tom London
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17233 None None None Never

  None (edit)
Description Per Thomas Jahr 2008-10-02 16:23:20 EDT
Created attachment 319291 [details]
Black border after enabling desktop effects.

Description of problem:
Black borders appears around all windows and menus after enabling desktop effects (see screenshot).

Version-Release number of selected component (if applicable):
The one in Fedora 10 beta.

Intel G965.
Comment 1 Tom London 2008-10-04 12:32:08 EDT
I am seeing the same thing on a Thinkpad X61 (Intel GM965), but not on a Thinkpad X60 (Intel 945).

In fact, I took the hard drive from my X60 (no border problem) and installed it in my X61 and booted it.  Same hard drive, same Rawhide system.  X61 has border problem, X60 does not.

[No /etc/X11/xorg.conf.]

My screenshot looks the same as #1.

I attach below 2 Xorg.0.log files: the first running on X61 with 965 graphics, the second running on X60 with 945 graphics.  [These are generated booting the same hard drive in the two systems.]
Comment 2 Tom London 2008-10-04 12:34:57 EDT
Created attachment 319463 [details]
Xorg.0.log booting up on Thinkpad X61 (Intel 965 graphics)

Xorg.0.log generated booting on Thinkpad X61.  Booted directly to level 5, gdm; started compiz via "fusion-icon".  fusion-icon says:

[tbl@tlondon ~]$ fusion-icon
[1] 3447
[tbl@tlondon ~]$  * Detected Session: gnome
 * Searching for installed applications...
 * Intel detected, exporting: INTEL_BATCH=1
 * Using the GTK Interface
 * Starting Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
 * Setting option Indirect Rendering to True
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
 * Setting option Indirect Rendering to False
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
 * Setting option Loose Binding to True
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
 * Setting option Loose Binding to False
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Attempted to unregister path (path[0] = org path[1] = freedesktop) which isn't registered
Comment 3 Tom London 2008-10-04 12:36:45 EDT
Created attachment 319464 [details]
Xorg.0.log booting up on Thinkpad X60 (Intel 945 graphics) (no fat borders)

Xorg.0.log generated from Thinkpad X60 (Intel 945 graphics).

Booted up directly to level 5, gdm.  Started compiz via "fusion-icon".

Do not get the above messages from compiz...
Comment 4 Tom London 2008-10-04 12:38:35 EDT
ouput of "lspci" on Thinkpad X61:

[root@tlondon log]# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
05:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
05:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
05:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
[root@tlondon log]# 

I believe Thinkpad X60 uses ICH7....
Comment 5 Tom London 2008-10-04 12:40:29 EDT
Version of compiz and mesa:

[root@tlondon ~]# rpm -qa compiz\* mesa\*
compiz-fusion-gnome-0.7.6-6.fc10.i386
mesa-dri-drivers-7.2-0.5.fc10.i386
compiz-fusion-extras-0.7.6-6.fc10.i386
compiz-manager-0.6.0-8.fc10.noarch
compiz-fusion-0.7.6-6.fc10.i386
compizconfig-python-0.7.6-1.fc10.i386
compizconfig-backend-gconf-0.7.6-1.fc10.i386
compiz-0.7.6-11.fc10.i386
compiz-gnome-0.7.6-11.fc10.i386
mesa-libGL-7.2-0.5.fc10.i386
mesa-libGL-devel-7.2-0.5.fc10.i386
compiz-fusion-extras-gnome-0.7.6-6.fc10.i386
mesa-libGLU-7.2-0.5.fc10.i386
mesa-debuginfo-7.2-0.2.fc10.i386
mesa-libGLU-devel-7.2-0.5.fc10.i386
[root@tlondon ~]#
Comment 6 Will Woods 2008-10-09 10:58:58 EDT
*** Bug 465588 has been marked as a duplicate of this bug. ***
Comment 7 Per Thomas Jahr 2008-10-09 14:31:03 EDT
So it seems like this is fixed upstream (although the field "External Bugs" says "No status"), but what package will carry the fix? Is it xorg-x11-drv-i810-some-version?
Comment 8 Tom London 2008-10-09 19:29:27 EDT
mesa-*-7.2-0.7.fc10.x86_64.rpm "works for me" on Thinkpad X61 (Intel 965 graphics).
Comment 9 Bug Zapper 2008-11-25 22:28:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Per Thomas Jahr 2009-02-08 07:35:33 EST
This one works for me with the alpha release of Fedora 11 (and I'm pretty sure it worked with Fedora 10 final as well). So I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.