Bug 465340 - loginAuth.pkl should be removed on "yum clean all"
loginAuth.pkl should be removed on "yum clean all"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 16:43 EDT by Rob James
Modified: 2009-09-02 07:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
yum-rhn-plugin creates creates a file at /var/spool/up2date/loginAuth.pkl that caches login information. If the contents of this file were to become corrupt, attempts to log in would result in a 404 error. Now, yum-rhn-plugin deletes this file at the end of each transaction and creates a new copy the next time that yum is run. Renewing this file ensures that cached login information is current and uncorrupted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:22:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1355 normal SHIPPED_LIVE yum-rhn-plugin bug fix and enhancement update 2009-09-01 06:50:58 EDT

  None (edit)
Description Rob James 2008-10-02 16:43:32 EDT
The RHN client tool now creates a file at /var/spool/up2date/loginAuth.pkl containing login caching. "yum clean all" should delete this file since it can become corrupt to force it to be recreated on next run.
Comment 5 Ruediger Landmann 2009-08-27 21:50:52 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
yum-rhn-plugin creates creates a file at 
/var/spool/up2date/loginAuth.pkl that caches login information. If the
contents of this file were to become corrupt, attempts to log in would 
result in a 404 error. Now, yum-rhn-plugin deletes this file at the end 
of each transaction and  creates a new copy the next time that yum is run. 
Renewing this file  ensures that cached login information is current and 
uncorrupted.
Comment 6 errata-xmlrpc 2009-09-02 07:22:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1355.html

Note You need to log in before you can comment on or make changes to this bug.