Bug 465361 - mkdumprd doesn't handle raid5 properly
mkdumprd doesn't handle raid5 properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 17:31 EDT by Doug Chapman
Modified: 2009-01-20 15:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:59:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct raid personality for raid5 (524 bytes, patch)
2008-10-03 08:40 EDT, Neil Horman
no flags Details | Diff
updated patch to handle raid 456 (401 bytes, patch)
2008-10-03 11:04 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-10-02 17:31:07 EDT
Description of problem:
when a kdump initrd is built on a system that boots off of raid5 it fails with:

No module raid5 found for kernel 2.6.18-117.el5, aborting.
Failed to run mkdumprd


that is because it appears to be looking for a module named raid5.ko but it is named raid456.ko.  


Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-44.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Neil Horman 2008-10-03 08:40:27 EDT
Created attachment 319356 [details]
patch to correct raid personality for raid5

This should fix it.  Please confirm and I'll check it in as soon as I can.  Thanks!
Comment 2 Doug Chapman 2008-10-03 11:04:55 EDT
Created attachment 319374 [details]
updated patch to handle raid 456

Neil,

I found a couple issues with your patch.  There are a couple different paths where it was trying to find a module named raid5.ko.  I moved this to a point that covers both.  Also, your patch converted any raid level to raid456 including raid 0, 1 and 01 which each have their own modules.

I tested this on my ia64 system with a raid5 root device.  I want to test at least on other raid level before we call this done.  I am planning on doing a raid0 install test case later today anyway so this is no extra work.
Comment 3 Doug Chapman 2008-10-03 13:30:43 EDT
This latest patch works with a raid0 root also so we should be OK now.
Comment 4 Neil Horman 2008-10-03 13:46:17 EDT
looks good, I'll check it in as soon as it gets the acks it needs.
Comment 8 errata-xmlrpc 2009-01-20 15:59:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0105.html

Note You need to log in before you can comment on or make changes to this bug.