Bug 465383 - Installation hangs after boot loader selection
Installation hangs after boot loader selection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 21:23 EDT by David
Modified: 2008-10-30 13:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 13:22:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output after installation hang (14.99 KB, text/plain)
2008-10-06 13:09 EDT, David
no flags Details
anaconda.log for this system (33.00 KB, text/plain)
2008-10-07 10:34 EDT, David
no flags Details
new anaconda.log (35.60 KB, text/plain)
2008-10-30 12:15 EDT, David
no flags Details

  None (edit)
Description David 2008-10-02 21:23:30 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start hard drive install
2. Select Custom Layout and format / partition
3. Select No boot loader and click next
  
Actual results:
Install hangs forever

Expected results:
Installation doesn't hang

Additional info:
Comment 1 Chris Lumens 2008-10-03 11:40:20 EDT
Is the machine completely frozen, or is it just anaconda?  Can you switch to tty3 or tty4 and see if there are any kernel-related error messages?
Comment 2 David 2008-10-03 12:18:06 EDT
I think it was completely frozen.  I know control-alt-delete didn't reboot it.  How would I get to tty[34]?  I thought the Alt-F* keys didn't work after the fancier GUI started.
Comment 3 Chris Lumens 2008-10-03 13:14:29 EDT
ctrl-alt-f3 will take you to tty3 once the UI starts up.
Comment 4 David 2008-10-06 13:02:42 EDT
It wasn't completely frozen after all (although I was right about
control-alt-delete not working).  Control-alt-f3 did get me to tty3.
The last message on tty3 was:

moving to step reposetup

I will attach the dmesg output.

Here is the f9 smolt profile for this system:

http://www.smolts.org/client/show/pub_71861abe-bcac-4fe0-9882-6d7999163874
Comment 5 David 2008-10-06 13:09:21 EDT
Created attachment 319572 [details]
dmesg output after installation hang
Comment 6 Chris Lumens 2008-10-06 16:39:50 EDT
How long did you wait before deciding it was hung?  Are there any messages on tty3 about attempting to fetch repodata?
Comment 7 David 2008-10-06 17:22:35 EDT
It's been 12 minutes right now.  I didn't see anything in tty3 about fetching
repodata.  I can get you the anaconda.log if you want.

I noticed on tty5 that it had mounted the root of the hard drive install device
to /mnt/isodir.  But I didn't see any messages anywhere that showed it trying
to loopback mount the iso file.
Comment 8 David 2008-10-07 10:34:08 EDT
Created attachment 319645 [details]
anaconda.log for this system

OK, I waited 17 hours and it made no more progress, so I copied the anaconda.log off and rebooted.
Comment 9 Chris Lumens 2008-10-07 10:46:08 EDT
I'm not seeing anything helpful in any of the log files.  We'll try to reproduce the problem here.
Comment 10 David 2008-10-07 11:09:01 EDT
OK.  Here is some more info about this system.  It is one of the first Dells
shipped with Ubuntu.  I installed Fedora on it as described here:

http://linux.derkeiler.com/Mailing-Lists/Fedora/2007-09/msg03816.html

I now have f9 on sda7 and am trying to install f10 beta on sda8.
I copied installation files to /tmp and /boot:

#sha1sum /tmp/images/install.img /tmp/Fedora-10-Beta-i386-DVD.iso
b01a0c9b5cd5e695317a11e53928f0a788a23ad0  /tmp/images/install.img
5490cd5430bf79da8fa6dd001f55b2994666d65e  /tmp/Fedora-10-Beta-i386-DVD.iso

#sha1sum /boot/*.install
b09654093e966ddbc8e131e4c776f8f2195a38d2  /boot/initrd.install
c5a4905790f66ab9fda06e422acbd33076a7642a  /boot/vmlinuz.install

Here is my grub configuration for this install:

title f10install
      root (hd0,6)
      kernel /boot/vmlinuz.install repo=hd:/dev/sda7:/tmp
      initrd /boot/initrd.install

I selected "no boot loader:" before it hung (I use grub from the original
Ubuntu partition).
Comment 11 David 2008-10-30 12:15:46 EDT
Created attachment 321954 [details]
new anaconda.log

F10 snap3 got farther than the original beta.  It now crashes after customizing packages.
Comment 12 Chris Lumens 2008-10-30 13:22:26 EDT
Since your original problem is fixed and the new log you've attached is fixed in bug 465127, I'll close this one out.  Thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.