Bug 465417 - Missing dependency on perl-XML-Twig
Missing dependency on perl-XML-Twig
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-Net-DBus (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 03:50 EDT by Grahame Bowland
Modified: 2008-11-11 03:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 03:33:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grahame Bowland 2008-10-03 03:50:01 EDT
Description of problem:
perl-Net-DBus will not function without the perl-XML-Twig package. This should be listed as a dependency of the package.

Version-Release number of selected component (if applicable):
Fedora 8, Fedora 9 versions of the package

How reproducible:
use perl-Net-DBus

Steps to Reproduce:
1. Install perl-Net-DBus without already having perl-XML-Twig
2. Run perl
3. Type 'use Net::DBus;'


Actual results:
use Net::DBus;
Can't locate XML/Twig.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/Binding/Introspector.pm line 57.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/Binding/Introspector.pm line 57.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/RemoteObject.pm line 58.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/RemoteObject.pm line 58.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/RemoteService.pm line 55.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus/RemoteService.pm line 55.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus.pm line 97.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/DBus.pm line 97.
Compilation failed in require at - line 1.
BEGIN failed--compilation aborted at - line 1.

Expected results:
No error (no output.)

Additional info:
Comment 1 Chris Weyl 2008-10-04 00:24:03 EDT
How did you install perl-Net-DBus?  Using yum/apt or by hand?  What does "rpm -q perl-Net-DBus" show?
Comment 2 Daniel Berrange 2008-10-04 12:08:48 EDT
I can only imagine you forceably removed XML-Twig, somehow broke the dependancies, or have a broken Perl include path, because the perl-Net-DBus package *does* have the dependancy required:

$ rpm -q perl-Net-DBus
perl-Net-DBus-0.33.6-2.fc9.i386
$ rpm -q --requires perl-Net-DBus | grep XML
perl(XML::Twig)
Comment 3 Chris Weyl 2008-10-04 12:54:51 EDT
(In reply to comment #2)
> I can only imagine you forceably removed XML-Twig, somehow broke the
> dependancies, or have a broken Perl include path, because the perl-Net-DBus
> package *does* have the dependancy required:

Yeah, that's sorta where I was going with that :-)  The latest available in F-8, 0.33.5-1, also has the proper dep.
Comment 4 Grahame Bowland 2008-10-05 19:46:35 EDT
Sorry, I've just realised that the problem was an internal RPM providing this perl module when it should not have. Please close this bug, apologies for wasting your time!
Comment 5 Chris Weyl 2008-11-11 03:33:14 EST
Not a problem :)

Note You need to log in before you can comment on or make changes to this bug.