Bug 465420 - Fedora won't boot after update
Fedora won't boot after update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 04:20 EDT by Ramsey Haddad
Modified: 2008-11-18 22:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 22:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramsey Haddad 2008-10-03 04:20:39 EDT
Hello,

After updating the kernel from 2.6.26.3-29 to 2.6.26.5-45 Fedora stopped booting with the error below every time.
(I typed this by hand so it might have spelling errors)
Thank you.


Activating logical volumes
  2 logical volume(s) in volume group "VolGroup00" now active
Trying to resume from /dev/VolGroup00/LogVol01
No suspend signature on swap, not resuming.
Create root device.
Could not find root-path dhcp option.
mkrootdev: could not determine nfs root target.
Mounting root filesystem.
mount: missing mount point
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Copying DHCP lease
cp: error opening /sysroot/dev/.dhclient-eth0.leases: No such file or directory
Mount failed for selinuxfs on /selinx: No such file or directory
Switching to new root and running init.
umounting old /dev
umounting old /proc
umounting old /sys
switchroot: mount failed: No such file or directory
Booting had failed.
Comment 1 Dave Jones 2008-10-03 12:18:52 EDT
what does your /etc/fstab look like ?

are you trying to use nfsroot ?
Comment 2 Ramsey Haddad 2008-10-03 16:37:47 EDT
$>cat /etc/fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults,usrquota,grpquota        1 1
UUID=70d1c680-dacc-423e-8c58-d0f2f819c5d0 /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
#UUID=30e7a57b-f963-4f13-8cc7-0b9f0fe633ef swap                    swap    defaults        0 0
UUID=fd899c34-fb15-4bd5-948c-6edb5649c2b3 /home/sda8                   ext3    defaults        1 1
/dev/VolGroup01/LogVol00 /home/sdb1                       ext3    defaults        1 1
Comment 3 Ramsey Haddad 2008-10-03 16:38:26 EDT
$>cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda3
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
#hiddenmenu
title Fedora (2.6.26.5-45.fc9.i686)
        root (hd0,2)
        kernel /vmlinuz-2.6.26.5-45.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb noirqdebug
        initrd /initrd-2.6.26.5-45.fc9.i686.img
title Fedora (2.6.26.3-29.fc9.i686)
        root (hd0,2)
        kernel /vmlinuz-2.6.26.3-29.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb noirqdebug
        initrd /initrd-2.6.26.3-29.fc9.i686.img
title Fedora (2.6.25.3-2.fc9.i686.xen)
        root (hd0,2)
        kernel /xen.gz-2.6.25.3-2.fc9.i686.xen
        module /vmlinuz-2.6.25.3-2.fc9.i686.xen ro root=/dev/VolGroup00/LogVol00 rhgb noirqdebug
        module /initrd-2.6.25.3-2.fc9.i686.xen.img
title Fedora (2.6.25.14-108.fc9.i686)
        root (hd0,2)
        kernel /vmlinuz-2.6.25.14-108.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb noirqdebug
        initrd /initrd-2.6.25.14-108.fc9.i686.img
title Ubuntu 8.04
        rootnoverify (hd0,1)
        chainloader +1
title Microsoft Windows XP Professional
        rootnoverify (hd0,0)
        chainloader +1
Comment 4 Ramsey Haddad 2008-10-03 16:43:25 EDT
$> Hello Dave :)

Things to note, I added the usrquota and grpquota options after following the F9 perfect server how-to forge article, but I don't use ispconfig, i use webmin if that should matter.

The noirqdebug option in grub is needed for my computer to boot otherwise i'll get the "nobody cared try irqpoll" message.

I have 3 OSs installed, yes please shoot me.

The break down of the 2 SATA harddrives:
/dev/sda is 160GB

/dev/sda1	ntfs	(for the unholy and bios updates)
/dev/sda2	ext3 	/boot (for ubuntu not fedora, the ubuntu grub is called first, from here i select fedora)
/dev/sda3	ext3	/boot (for fedora and fedora grub is installed here)
/dev/sda4	extended
/dev/sda5	swap 	(for ubuntu)
/dev/sda6	ext3	/ (for ubuntu)
/dev/sda7	lvm
	/dev/mapper/VolGroup00-LogVol00	/ (for fedora)
	/dev/mapper/VolGroup00-LogVol01	swap (for fedora)
/dev/sda8	ext3	unused


/dev/sdb is 300GB
/dev/sdb1	lvm
	/dev/mapper/VolGroup01-LogVol00	/home (for fedora and ubuntu)
Comment 5 Dave Jones 2008-10-03 16:58:19 EDT
This part..

Could not find root-path dhcp option.
mkrootdev: could not determine nfs root target

is where things are going horribly wrong. Why it's even trying to use nfs is a mystery to me.  It looks like the initrd is very confused.   Peter, any ideas ?
Comment 6 David Cantrell 2008-10-03 17:02:54 EDT
(In reply to comment #5)
> This part..
> 
> Could not find root-path dhcp option.
> mkrootdev: could not determine nfs root target
> 
> is where things are going horribly wrong. Why it's even trying to use nfs is a
> mystery to me.  It looks like the initrd is very confused.   Peter, any ideas ?

nash is currently using libdhcp, which does not support the root-path option.

Peter, can we move to dhclient in the initrd so it can pick up root-path?
Comment 7 Ramsey Haddad 2008-10-06 10:32:41 EDT
Dear Fedora Devs,
I'm going to try out a different linux distro, and unfortunately fedora is the one that has to go this time. Is there anything you need for me to do to help you out with fixing this bug before uninstalling fedora, like logs, config files, running some commands, etc.
Comment 8 John Ellson 2008-10-10 15:28:13 EDT
Check that this isn't caused by BZ #462228

NFS was one of the symptoms of ltsp-client being installed on a server,
Comment 9 Ramsey Haddad 2008-10-12 09:05:04 EDT
Hey John,

ltsp could be it, when i used to run /sbin/ifconfig i used to get ltsp along with eth0 and the loopback and i remember seeing it starting when it's booting. 

i don't remember consciously installing ltsp-client but it's very likely that it did have it installed.

thank you for your help.

Note You need to log in before you can comment on or make changes to this bug.