Bug 465454 - kernel-xen won't boot after install - Unkown option com2
kernel-xen won't boot after install - Unkown option com2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: booty (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: beta
: ---
Assigned To: Peter Jones
Release Test Team
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 08:21 EDT by Alexander Todorov
Modified: 2009-01-20 16:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-03 08:21:55 EDT
Description of problem:
After install with a key that unlocks all repos the system can't boot. 

The message on the console is:

Loading.: Red Hat Enterprise Linux Server                           
Starting: Red Hat Enterprise Linux Server
near line 7: Unkown option com2
near line 1: Unkown option 
forcing interactive mode due to config file error(s)

ELILO boot: 


Version-Release number of selected component (if applicable):
booty-0.80.6-3.

How reproducible:
Always (on selected hardware)

Steps to Reproduce:
1. Install @virtualization group
2. Both with linux console=ttyS1,115200 (we use serial console)
3.
  
Actual results:
System doesn't boot

Expected results:
System boots

Additional info:
After the install:

sh-3.2# cat /boot/efi/efi/redhat/elilo.conf 
prompt
timeout=20
default=linux
relocatable

image=vmlinuz-2.6.18-117.el5xen
        vmm=xen.gz-2.6.18-117.el5 com2=115200
        label=linux
        initrd=initrd-2.6.18-117.el5xen.img
        read-only
        root=/dev/VolGroup00/LogVol00
        append="-- console=ttyS1,115200"

image=vmlinuz-2.6.18-117.el5
        label=linux-base
        initrd=initrd-2.6.18-117.el5.img
        read-only
        root=/dev/VolGroup00/LogVol00
        append="console=ttyS1,115200"

if we remove the com2= from the config file the system boots fine.
Comment 5 Peter Jones 2008-10-07 11:17:07 EDT
This should be fixed with booty-0.80.6-4 .
Comment 10 errata-xmlrpc 2009-01-20 16:05:46 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0138.html

Note You need to log in before you can comment on or make changes to this bug.