Bug 465471 - yum update fails, looks like a fedora mirror problem
yum update fails, looks like a fedora mirror problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 10:29 EDT by Bill C. Riemers
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 14:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar.gz of /etc/yum.repos.d (2.15 KB, application/octet-stream)
2008-10-03 11:34 EDT, Bill C. Riemers
no flags Details

  None (edit)
Description Bill C. Riemers 2008-10-03 10:29:39 EDT
Description of problem:

When I do yum update I get an error that repomd.xml can not be retrieved for either updates-newkey or updates.

Version-Release number of selected component (if applicable):

3.2.19

How reproducible:

Always, for the last 24 hours or so.

Steps to Reproduce:
1. yum update
2. yum update --disablerepo=update-newkey
3.
  
Actual results:

[docbill@hartnell ~]$ sudo yum update clean
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates-newkey. Please verify its path and try again
[docbill@hartnell ~]$ sudo yum update --disablerepo=updates-newkey
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates. Please verify its path and try again


Expected results:

successful update

Additional info:
Comment 1 seth vidal 2008-10-03 10:45:29 EDT
What do your .repo files have in them? also are you using any sort of proxy?
Comment 2 Bill C. Riemers 2008-10-03 11:34:07 EDT
Created attachment 319382 [details]
tar.gz of /etc/yum.repos.d

For the most part they are the standard repo files.  I did make a couple of changes trying to workaround this problem (based on blogged comments I read).
None of the tips worked so the changes are comment out the changes and went back to the original mirror settings.

It looks like I don't need to update to see the error.  Even requesting a repolist causes the error:

[root@hartnell ~]# yum repolist
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates-newkey. Please verify its path and try again

Bill
Comment 3 Bill C. Riemers 2008-10-03 11:34:57 EDT
BTW.  No proxy.   I do have a vpnc connection to Red Hat, but the same error occurs when I am not connected via vpnc.
Comment 4 Bill C. Riemers 2008-10-03 11:50:45 EDT
BTW.  If I open up the mirrorlist:

 http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f9.newkey&arch=x86_64 

in my webbrowser I get the message '# Server error'.


If I open up:

http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-9&arch=x86_64

in my webbrowser, I get a list of mirrors.
Comment 5 Bill C. Riemers 2008-10-03 12:53:02 EDT
It looks like the update and update.newkeys repositories are working again.
Comment 6 seth vidal 2008-10-03 14:03:41 EDT
Okay, looks like a temporary mirrorlist issue.

Note You need to log in before you can comment on or make changes to this bug.